Programs sometimes fail to load

mwaite

Member
Licensed User
I'm not reporting this a bug, because knowing how the PocketPC is it may just be a Microsoft thing...

On occassion, perhaps a couple times a week, I find my B4PPC applications fail to load. When I click the icon to launch a program, I get stuck indefinetely on the WaitCursor, forcing a soft-reset.

It happens on different programs, using different librarys (as far as I can tell I can't find a similarity).

And I have had two other people tell me they have seen the same thing with one of my programs on their PDAs as well.

I just dont' know how to handle this because by appearance it looks like my program never even makes it to App_Start.

Anyone else have this happen on occasion? Any ideas on how to troubleshoot?
 

RandomCoder

Well-Known Member
Licensed User
I too have had this happen once or twice to me. But then I like to tweak the registry from time to time and so I put it down to this.
You shouldn't need to soft reset, just go to the system settings>memory>running programs and kill the B4PPC program then re-try loading it again.

Regards,
RandomCoder
 

RandomCoder

Well-Known Member
Licensed User
I've only experienced it with B4PPC although I have to admit that I don't use contacts and calendar all that often.

Regards,
RandomCoder
 

RandomCoder

Well-Known Member
Licensed User
It's the B4PPC application that has failed to load. Click the icon, see the wait cursor then endlessly wait. Have to stop the program and retry loading again.
It's not a big problem for me, but it appears that I'm not the only one that's experienced it.

Regards,
RandomCoder
 

mwaite

Member
Licensed User
Erel, I sent you an application that occasionally fails to load.
 

Erel

Administrator
Staff member
Licensed User
Looks like a very nice application.
I've opened it and closed it about 30 times and I didn't encounter any problem.
I recommend you to create a log file so you will be able to see when does the program fail to load.
You should also check for endless loops that may cause the application to not close completely.
Make sure that all the HTTP / FTP connections are closed.
 
Top