Android Question Ran AVD manager and now my app no longer compiles.


Well-Known Member
Licensed User
Longtime User
Things were working fine but I wanted to check my layout with a small phone.
Ran SDK manager and installed everything recommended.
Got this error when compiling:
B4A Version: 10.70
Parsing code.    (0.46s)
    Java Version: 11
Building folders structure.    (2.41s)
Running custom action.    (0.11s)
Compiling code.    (0.72s)
ObfuscatorMap.txt file created in Objects folder.
Compiling layouts code.    (0.05s)
Organizing libraries.    Error
Maven artifact not found: androidx.annotation/annotation-experimental
When back and found this and installed it.:
Opened SDK manager again and it gave me several other things to install so I did that.
Found a link here that was a similar problem so I went back and found this and installed it.

Got this error:
Compiling generated Java code.    (13.82s)
Convert byte code - optimized dex.    Error
Uncaught translation error: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
1 error; aborting

I changed the min-sdk-version from 5 to 26 but it still gives the same error.

Then I looked at the first error and saw androidX and I realize this is a new computer and I hadn't run jetifier so I did that.

Still get the same error.

Any help appreciated.

And aside from just fixing the problem I would really like to know what happened.