Android Question Rapid Debugger fails with a specific app

JordiCP

Well-Known Member
Licensed User
Hi,

I have spent several hours trying to solve it. When I try to debug a specific app, I get this error
java.lang.RuntimeException: java.io.EOFException
at anywheresoftware.b4a.shell.Shell.virtualAssets(Shell.java:169)
at anywheresoftware.b4a.shell.Shell.start(Shell.java:102)
at anywheresoftware.b4a.ShellBA.raiseEvent2(ShellBA.java:92)
at de.pokethardware.zpocketethernet.main.afterFirstLayout(main.java:96)
at de.pokethardware.zpocketethernet.main.access$000(main.java:17)
at de.pokethardware.zpocketethernet.main$WaitForLayout.run(main.java:82)
at android.os.Handler.handleCallback(Handler.java:815)
at android.os.Handler.dispatchMessage(Handler.java:104)
at android.os.Looper.loop(Looper.java:207)
at android.app.ActivityThread.main(ActivityThread.java:5710)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:900)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:761)
Caused by: java.io.EOFException
at libcore.io.Streams.readFully(Streams.java:83)
at java.io.DataInputStream.readInt(DataInputStream.java:103)
at anywheresoftware.b4a.shell.Shell.virtualAssets(Shell.java:141)
... 12 more
or also
java.lang.RuntimeException: java.net.SocketException: Socket closed
at anywheresoftware.b4a.shell.Shell.virtualAssets(Shell.java:169)
at anywheresoftware.b4a.shell.Shell.start(Shell.java:102)
at anywheresoftware.b4a.ShellBA.raiseEvent2(ShellBA.java:92)
at de.pokethardware.zpocketethernet.main.afterFirstLayout(main.java:96)
at de.pokethardware.zpocketethernet.main.access$000(main.java:17)
at de.pokethardware.zpocketethernet.main$WaitForLayout.run(main.java:82)
at android.os.Handler.handleCallback(Handler.java:815)
at android.os.Handler.dispatchMessage(Handler.java:104)
at android.os.Looper.loop(Looper.java:207)
at android.app.ActivityThread.main(ActivityThread.java:5710)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:900)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:761)
Caused by: java.net.SocketException: Socket closed
at libcore.io.Posix.recvfromBytes(Native Method)
at libcore.io.Posix.recvfrom(Posix.java:189)
at libcore.io.BlockGuardOs.recvfrom(BlockGuardOs.java:250)
at libcore.io.IoBridge.recvfrom(IoBridge.java:584)
at java.net.PlainSocketImpl.read(PlainSocketImpl.java:488)
at java.net.PlainSocketImpl.access$000(PlainSocketImpl.java:42)
at java.net.PlainSocketImpl$PlainSocketInputStream.read(PlainSocketImpl.java:242)
at java.io.InputStream.read(InputStream.java:162)
at java.io.BufferedInputStream.fillbuf(BufferedInputStream.java:149)
at java.io.BufferedInputStream.read(BufferedInputStream.java:295)
at libcore.io.Streams.readFully(Streams.java:81)
at java.io.DataInputStream.readInt(DataInputStream.java:103)
at anywheresoftware.b4a.shell.Shell.virtualAssets(Shell.java:141)
... 12 more

This happens just at the start, before Activity_Create appears in the logs.

I have seen some questions related to it in the past but haven't found an answer that solves my problem.

Some additional info:
  • I am using USB for debugging.
  • Also tried with other apps, and it works normally.
  • In release mode, the app also works normally.
  • I can't use the legacy debugger because a strange error appears when I use ResumableSubs (as I'm not sure if they should work with the legacy debugger, this is not the main concern in this question)
  • The assets size is less than 250KB. I can run other apps with a larger assets size normally using Rapid Debugger.
  • Have tested with both #DebuggerForceStandardAssets set to True or False, same result.

So the only solution I can see now is to remove the ResumableSubs and place workarounds instead, and then I'd be able to work with the legacy debugger...but I'd prefer to solve this issue if possible.

Any hint?
 

JordiCP

Well-Known Member
Licensed User
Hi Pendrush,
Tested it but unfortunately the same result. Perhaps combined with some other debugger switch...not sure.

Thanks anyway :)
 
Upvote 0
Top