Android Question Rapid Debugger Problem

Stefano Di Chiano

Active Member
Licensed User
Hi,
yesterday I was trying to run a project in Debug mode using Bluestacks as emulator. Though, the program didn't start and after a while a message appears on screen saying: "Rapid Debugger failed to connect. Try again". Also, the log remains empty. Today I tried a different project and I got the same problem.
I already tried the USB Debugging, B4A Bridge, Restarting ADB Server and compiling in Release mode. Nothing seems to work.
I looked up on the forum for similar problems and I saw it could be related to the java version, so I updated it, but I still get the message.
Both the projects I tried use Firebase if that could be a lead to solve the issue.
Thanks for the help.
Edit: other projects, much simpler ones that don't use Firebase, work well.
 
Last edited:

Stefano Di Chiano

Active Member
Licensed User
But i'm not using AdMob in one of the two projects.
I came to the conclusion that the problem has to be related to firebase somehow, cause I tried to remove it from the project (commenting the code lines using firebase, unselecting the library and removing the snippets from the manifest) and it worked. When I reintroduced firebase the problem reappeared.
 
Upvote 0

Stefano Di Chiano

Active Member
Licensed User
Ok, I'll try to give more informations.
The first time I had this issue was when I tried to add AdMob to a project I already had. My app is already published, so I linked it on AdMob, where I linked a Firebase project. I followed the instructions on https://www.b4x.com/android/forum/threads/integrating-firebase-services.67692/ to integrate firebase. Then I followed the instructions on https://www.b4x.com/android/forum/t...b-ads-integrated-with-firebase-backend.67710/ to add a banner and an interstitial.
I tried to run but the project didn't even start after compiling and I get the message on screen saying "Rapid Debugger failed to connect. Try again".
On another project then I tried to integrate FirebaseAuth following the same instructions and those on https://www.b4x.com/android/forum/threads/firebaseauth-authenticate-your-users.67875/. I tried to run this project as well but I get the same message.
I guess that you haven't added the new requirement in FirebaseAdMob v1.6.
I'm trying to follow this guide https://www.b4x.com/android/forum/threads/firebaseadmob-v1-6.108552/#post-678483. But when I add
B4X:
Dim MobileAds As MobileAds
it says "unknown type: MobileAds". I don't see any MobileAds library in the libraries tab.
AddManifestText(
<uses-sdk android:minSdkVersion="5" android:targetSdkVersion="28"/>
<supports-screens android:largeScreens="true"
android:normalScreens="true"
android:smallScreens="true"
android:anyDensity="true"/>)
SetApplicationAttribute(android:icon, "@drawable/icon")
SetApplicationAttribute(android:label, "$LABEL$")
CreateResourceFromFile(Macro, Themes.DarkTheme)
'End of default text.
CreateResourceFromFile(Macro, FirebaseAnalytics.GooglePlayBase)
CreateResourceFromFile(Macro, FirebaseAnalytics.Firebase)
CreateResourceFromFile(Macro, FirebaseNotifications.FirebaseNotifications)
CreateResourceFromFile(Macro, FirebaseAnalytics.FirebaseAnalytics)
CreateResourceFromFile(Macro, FirebaseAdMob.FirebaseAds)
CreateResourceFromFile(Macro, FirebaseAuth.FirebaseAuth)
'AddReplacement($ADMOB_APP_ID$, ca-app-pub-1042754621421283~5963963613)
javac.exe: C:\Program Files\Java\jdk1.8.0_221\bin\javac.exe
android jar: C:\Android\platforms\android-28\android.jar
sdkmanager.bat: C:\Android\tools\bin\sdkmanager.bat
additional libraries: C:\Program Files (x86)\Anywhere Software\Basic4android\Basic4android\Libraries
 
Upvote 0

DonManfred

Expert
Licensed User
additional libraries: C:\Program Files (x86)\Anywhere Software\Basic4android\Basic4android\Libraries
No, this looks like it is the INTERNAL libraryfolder.

At least it is the wrong path for any Additional library folder as ProgramFiles is a restricted folder.
You should use a nonrestricted Folder for the additional libraries.
 
Upvote 0

Stefano Di Chiano

Active Member
Licensed User
All right. I updated B4A, now my version is 9.80.
For the second step, should I make a new Android folder and download everything again or should I keep the folder I had until now?
 
Upvote 0

Stefano Di Chiano

Active Member
Licensed User
Ok, done. But I still get the error.
Edit: it seems to work now, but only if using B4A Bridge. Otherwise it doesn't work.
 

Attachments

  • erroreb4a.png
    erroreb4a.png
    6.3 KB · Views: 49
Last edited:
Upvote 0
Top