.sbp file association in the Device

Discussion in 'Code Samples & Tips' started by Cableguy, May 11, 2007.

  1. Cableguy

    Cableguy Expert Licensed User

    Hi,

    After a few attemps i managed to associate the b4ppc generated files (.sbp) to its original creator (b4ppc) and respective icon...

    Using a regestry editor (or even the regestry library if anyone is willing to create an aplet to do this), Like PHM Regedit, go to the following Key:

    HKEY_CLASSES_ROOT

    add Key:

    .sbp (including the dot)

    Inside the .sbp ad the values:

    Name - value
    Content Type - basic4ppc
    Default - sbpfile

    Go back one level and add the Key:

    sbpfile

    Inside this key create two more:

    DefaultIcon
    Shell

    Inside DefaultIcon add the value

    Default - \Program Files\Basic4ppc\Basic4ppc.exe,0 (this is the path were b4ppc is installed and may difer from yours...the last zero is needed to indicate the icon)
    Go back to the shell key and add insid it the folllowing keys:

    Open\Command

    Inside command add the value:

    Default - "\Program Files\Basic4ppc\Basic4ppc.exe" "%1" ( dont forget the commas, and again this is the b4ppc install path)
    EDIT: though this is true, its doesn't seem to work with B4ppc files, it just launches the B4ppc editor in a blank project upon tapping a sbp file
    ALthoug I'm not sure if its necessary, I did a soft-reset after the regestry alteration....

    As Usual, messing with the regestry is something to do with extra care, any "bad" key can transform your device in a brick untill hard-reset...
     
    Last edited: May 11, 2007
  2. taximania

    taximania Well-Known Member Licensed User

    I tried this with PHM RegEdit, what type of 'values', DWord, binary, string etc should I be adding.

    The options available in PHM don't match what your telling me to add ?
     
  3. Cableguy

    Cableguy Expert Licensed User

    I used PHM, all values are REG_SZ wich are Dword or String, and are also the default type...
     
  4. taximania

    taximania Well-Known Member Licensed User

    Thankyou for your quick reply :sign0060:

    I will try again tomorrow :sign0087:
    I'm very limited at present using this laptop.

    I've still not sorted my laptop out yet.
    Waiting for a new DVD drive :(
     
  5. bdiscount

    bdiscount Active Member Licensed User

    sbp associate

    I can double click on a sbp file in file explorer or resco explorer and it brings up basic4ppc. wihout going thru the registry as you say.
     
  6. Cableguy

    Cableguy Expert Licensed User

    Hi, I'm using WM6, and it always reported me,that no program was associated with the filetype.
    That's what brought me Here....
    What SO are you using?
     
  7. bdiscount

    bdiscount Active Member Licensed User

    associate

    I'm using wm5 and will probably never change to wm6
     
  8. Cableguy

    Cableguy Expert Licensed User

    Ok,
    So I downgraded to WM5 and installed RescoExplorer....And can't get it to load on tap...B4ppcStarts always an empty project...Maybe in V5 this will be adressed...
     
  9. bdiscount

    bdiscount Active Member Licensed User

    It would be nice as I can't remember the file I tapped when I get in B4ppc
     
Loading...