B4J Question Security issues with okhttp when runnig Exe

gabriels

Member
Licensed User
Hi there, having this problem for the last few days.
OS : Windows 10 - for development and production
When running in develop , everything is OK . When I try to run the Exe in production , everything works fine until okHTTP functions are invoked .
If the EXE is generated in production env , okhttp issues doesn't arise.
I have tried with java 11 and 14 versions , it is the same
I have tried installing app with InnoSetup , it is the same

When I run bat file for debugging mode : run_debug.bat, error list is shown -image -, and makes me think that the error is related with some security issues about okhttp library -
Maybe there is something in \build\lib\security files, that it is missing ...
Generate EXE on customer's site is not an option

1610926876095.png


If you need more details, just ask me.
Thanks for help
Regards !
 
Last edited:

MarcoRome

Expert
Licensed User
Add the following lines to the initial code you project B4J, first "Build Standalone Package":

B4X:
#Region Project Attributes
    #MainFormWidth: ...
    #MainFormHeight: ...
#End Region

'***IN YOUR CASE THIS***
#PackagerProperty: IncludedModules = jdk.crypto.ec

''If using jPOI library add:
'#PackagerProperty: AdditionalModuleInfoString = opens schemaorg_apache_xmlbeans.system.sD023D6490046BA0250A839A9AD24C443;
'#PackagerProperty: IncludedModules = jdk.charsets
'
''If using WebView add:
'#PackagerProperty: IncludedModules = javafx.web
'
''If using jGoogleMaps add:
'#PackagerProperty: IncludedModules = javafx.web
'#PackagerProperty: AdditionalModuleInfoString = exports com.lynden.gmapsfx.javascript.event;
 
Upvote 0
Top