Android Question SMB Suddenly stopped working over night

ElliotHC

Active Member
Licensed User
My project has been working perfectly up to this morning. I've gone to power up both Laptop with shared folder and Tablet with SMB log on to laptop accessing shared folder and now it's not downloading. B4A Bridge working perfectly so I know they are both on the same usual network..

Could it have been a windows update?

Tried restarting both, restarting adapter, removing and re-adding the share.. Still no files downloading.. (Success=False)

Reverted back to a previous version from a few days ago.. (Success=False)

Tried the App on my android phone (Success=False)

So it has to be the laptop or connection.

Anyone know where I access the data which shows if it's connecting?
 

ElliotHC

Active Member
Licensed User
KB2310138 Update last night may have caused this.. Anyone have any experience in allowing SMB to work through security updates?

Can anyone else on Windows 7 Confirm that they've had this update installed last night

Security Intelligence Update for Microsoft Security Essentials - KB2310138 (Version 1.303.1889.0)
Installation date: ‎17/‎10/‎2019 07:38
Installation status: Successful
Update type: Recommended
Install this update to revise the files that are used to detect viruses, spyware, and other potentially unwanted software. Once you have installed this item, it cannot be removed.
More information:
https://go.microsoft.com/fwlink/?linkid=2007160
Help and Support:
https://go.microsoft.com/fwlink/?LinkId=52661

And that SMB is now not working?
 
Last edited:
Upvote 0

RJB

Active Member
Licensed User
Hi,
I downloaded the library from the above link and put the files in the additional libraries folder.
The example gives the following error:
B4X:
Compiling generated Java code.    Error
Cannot find: C:\Program Files (x86)\Anywhere Software\Basic4android\libraries\jcifs-ng-2.1.2.jar
Any ideas?
Thanks
 
Upvote 0

RJB

Active Member
Licensed User
Yes, that did the trick. Now just need to go through all of the old stuff to see if I can get it working with this library!
 
Upvote 0

akb

Member
Licensed User
I had the same problem today with an app I wrote and don't have time to change the app as my client uses this for seasonal fruit picking and they are about to start picking.
I managed to come up with the following solution:

Press Windows + R and type “gpedit.msc” in the dialogue box and press Enter.
Once in the editor, navigate to the following path:
Computer Configuration > Administrative Templates > Network > Lanman Workstation
At the right side, you will see an entry named “Enable insecure guest logons”. Double-click it to change its properties.
Change the option from “Not Configured” to “Enabled”. Press Apply to save changes and exit. Restart the computer.

I found the idea for the solution here: https://appuals.com/fix-cannot-access-network-shares-after-update-1709/

It looks to me like a recent MS update has changed the default setting for this from Enabled to Disabled.

I know this isn't the best long term solution and I will need to update the app to use SMB 2 or 3, but it has solved an immediate problem for me.
 
Upvote 0
Top