Android Question [SOLVED] B4A v9.30 BETA AndroidX SDK error TabLayout.SetViewPager

scsjc

Well-Known Member
Licensed User
i try with another app, and get this error:



B4X:
B4A Version: 9.30 BETA #2
Java Version: 11
Parsing code.    (0.22s)
Building folders structure.    (0.02s)
Compiling code.    (0.21s)
   
ObfuscatorMap.txt file created in Objects folder.
Compiling layouts code.    (0.01s)
Organizing libraries.    (0.00s)
    (AndroidX SDK)
Generating R file.    (0.00s)
Compiling generated Java code.    Error
B4A line: 319
TabLayout.SetViewPager(vp)
src\xxxxxxxx\xxxxxx\com\xxxxxxx.java:594: error: package android.support.v4.view does not exist
mostCurrent._tablayout.SetViewPager((android.support.v4.view.ViewPager)(mostCurrent._vp.getObject()));

i read something to fix this error but i dont know where/how put (manifest... startmaincode...)


B4X:
import androidx.core.view.ViewCompat
 
Top