iOS Question [SOLVED] Cant built B4i-bridge.

techknight

Well-Known Member
Licensed User
it has been a long while since I have messed around with B4i, so I had to update all my certs again.

I am rebuilding the B4i-bridge app, but this keeps happening:

B4i Version: 5.30
Parsing code. (0.00s)
Building folders structure. (0.01s)
Compiling code. (0.00s)
Building designer app. (0.00s)
Building Xcode project (0.09s)
Sending data to remote compiler. Error
Illegal characters in path.

What?
 

techknight

Well-Known Member
Licensed User
I am not building a project. Trying to build the B4I_Bridge to get it over to my Tablet.

The open project is: Z:\Misc\B4I Examples\B4XDrawer
 

techknight

Well-Known Member
Licensed User
I have never had issues in the past with spaces? I still have my IOS projects folders with apps I built in the past without error.

I wont be able to build any projects then because it breaks my entire file system and directory structure that I have built up for years.
 

techknight

Well-Known Member
Licensed User
I moved the example project out on the Root of my C drive. Now its just C:\B4XDrawer

Same thing,
 

techknight

Well-Known Member
Licensed User
None of the keys files in my Keys folder have spaces or other weird characters, Just checked to make sure.
 

techknight

Well-Known Member
Licensed User
I do have both Dev and Dist certs in my keys folder.

At the Project Attributes, I have this:

B4X:
    #IF DEBUG
        #ProvisionFile: "MD_Development.mobileprovision"
        #CertificateFile: "ios_development.cer"
    #Else
        #ProvisionFile: "MD_ADHOC_Distribution.mobileprovision"
        #CertificateFile: "ios_distribution.cer"   
    #END IF
Would that affect anything?
 

techknight

Well-Known Member
Licensed User
Thoughts? I am stuck here. Nothing compiles. everything throws this same error.

I am using a local mac builder BTW. It is running on the Mac, connected. Also it is B4i 5.30 from Sept.
 

techknight

Well-Known Member
Licensed User
I might be getting closer. Trying to run b4i builder on the mac in terminal, it keeps saying failed to find xcode version.

Its running 10.1.
 

techknight

Well-Known Member
Licensed User
Nope, False alarm.

It was an issue, but I had to go into xcode and fix the command line tools path. Once I did that, the builder ran. Still giving me illegal characters in path error. GRRRRRR
 

techknight

Well-Known Member
Licensed User
Its something going on with the keys certs. Something is wrong.

The problem seems it does NOT like having both a dev, and a dist key and provision inthe same folder. That sucks really. Need to fix it so I dont have to keep swapping keys in and out, that gets old, although I could have sworn you fixed this in a previous update?

I moved the development keys into another folder, and left the adhoc distribution keys in place. This fixed the illegal characters error. But its now generating a new one:

B4X:
Out: Build settings from command line:
    ARCHS = armv7 arm64
    CODE_SIGN_IDENTITY = iPhone Distribution: john doe(XXXXX) <-- removed cert identity.
    CONFIGURATION_BUILD_DIR = /Applications/B4iBuildServer/UploadedProjects/<user id>/Payload
    OTHER_CODE_SIGN_FLAGS = --keychain <user id>
    PRODUCT_NAME = B4i-Bridge
    PROVISIONING_PROFILE = 0dc3ce1b-712a-4b84-a4f3-eb02f952dc5f

note: Using new build system
note: Planning build
note: Constructing build description
Build system information
error: "B4iProject" requires a provisioning profile. Select a provisioning profile for the "Release" build configuration in the project editor. (in target 'B4iProject')


Error: ** BUILD FAILED **
 

techknight

Well-Known Member
Licensed User
Narrowed down the illegal characters issue.

the provisionfile, and certificatefile does NOT like the quotes in there. Whoops. Man, that broke things in a cryptic way! So this thread is solved, NEed to start a new one on the new issue.
 
Top