iOS Question [Solved] Crash at startup in Release

Marcus Araujo

Licensed User
Longtime User
Hello everyone, this is driving me nuts... debug mode works fine. Release mode doesn't even start: it crashes while asking to allow notifications.

Adhoc/debug: OK
Adhoc/release: crashes at startup
AppStore/release: crashes at startup*

*According to AWS Device Farm error log (tested on an iPhone 8), there are two different errors:
1 - Unable to generate launch image for big2be.estancia.estan.iphone because the app has no valid launch interfaces.
2 - No valid 'aps-environment' entitlement string found for application 'big2be.estancia.estan.iphone' (null).

I tried recreating all certificates and profiles prior to compilation in release mode, same result.

Main's code (and provision files) contains aps-environment.
#Entitlement: <key>aps-environment</key><string>production</string>

Any ideas?

Marcus Araujo

Licensed User
Longtime User
Thank you. The problem was with the Firebase. I deleted and recreated GoogleService-Info.plist and it worked. I'm still not sure why it worked in Debug mode only. Thanks!

If anyone's interested, the error is as below:
`[FIRApp configure];` (`FirebaseApp.configure()` in Swift) could not find a valid GoogleService-Info.plist in your project. Please download one from
Upvote 0