iOS Question The following build commands failed: CodeSign Payload/xxx.app

schimanski

Well-Known Member
Licensed User
Suddenly, it is not possible to install my app on my phone. In debug and release, I get the following error in the textfile. I had the same problem a few day ago, but with downloading the certs an provision-files, i got it at work. Now, it doesn't. I use the hosted builder and I also wait for a few hours, if the tokens are rejected....

Edit:

I have changed the pushadhoc.mobileprovision with a provision-file from another app and the app will be installed. So it has to be a problem with the provision-file.
 

Attachments

Last edited:

schimanski

Well-Known Member
Licensed User
After compiling with another provision-file, I took the old one and everything runs fine...don't know why..
 

schimanski

Well-Known Member
Licensed User
I'm using the hosted builder and in the last days, I sometimes get the following exception, when compiling the app in release and debug mode. I thought, that it is a problem with the certificates and provisioning files because I have changes my email-adress/apple-ID of my developer-account, so I rebuild them. But the same problem. If I change the push-provisioning profile once with the developer provisioning and back to the pushhadhoc, the compile will be successfully.
Since the same time, it is always not possible to compile the app in release on the device with my distribution push provisioning profile. Before, it ws no problem..

Signing Identity: "iPhone Distribution: xxxx xxxxxx (LV4ACM64X5)"
Provisioning Profile: "pushadhoc"
(145c5953-aae0-49df-b09b-3c12360617c8)

/usr/bin/codesign --force --sign 1D1621E3D6ED2FD4CED58B21280CB1D7EDABAC0F --keychain <user id> --entitlements /Users/administrator/Documents/UploadedProjects/<user id>/build/B4iProject.build/Release-iphoneos/B4iProject.build/EIS.app.xcent --timestamp=none /Users/administrator/Documents/UploadedProjects/<user id>/Payload/EIS.app
1D1621E3D6ED2FD4CED58B21280CB1D7EDABAC0F: no identity found
Command /usr/bin/codesign failed with exit code 1


Error: ** BUILD FAILED **


The following build commands failed:
CodeSign Payload/EIS.app
(1 failure)
 

schimanski

Well-Known Member
Licensed User
Yes, thats correct. And also if I wait a few hours and compile it again, it sometimes works again.
 

schimanski

Well-Known Member
Licensed User
I don't need it. But the problem exists with my pushadhoc provision profile and i mentioned, that if i change the provision profile for one compile and than back to the old pushadhoc, it almost works.
Yesterday, I deleted all my certs and provision profiles and begon with buildung new ones. For developing, it seems to be working without problems. Today, I will renew my distribution cert and push provision profiles. After testing it, i call back...
 

schimanski

Well-Known Member
Licensed User
I made all certs and provisioning profiles new, but the same result as the error message in Post #1. For Release, I change the certificateFile from development to distribution
as the followed code. That sould not be a problem, or?:(

B4X:
#If RELEASE
        #CertificateFile: ios_distribution.cer
        #ProvisionFile: pushadhoc.mobileprovision       
    #Else
        #CertificateFile: ios_development.cer
        #ProvisionFile: pushadhoc.mobileprovision
#End If
 

schimanski

Well-Known Member
Licensed User
I made all my certs and provision profiles again and now it seems to run. I'm not sure, what the reason for these sudden problems was, but it could be, that changing my apple-id in my developer account had something to do with it. For a short time it seems, that my account based on both ids, the new and the old one. Now, my old id seems to be rejected...
 

netkomm

Active Member
Licensed User
Hi Erel,

I am facing the same issue: this afternoon while working it stopped. Then changing the certificate file to distribution it worked again.

Tonight while working... few minutes ago got stuck and can't compile any more.

B4X:
CodeSign Payload/Picchio\ Beach.app
    cd /Users/administrator/Documents/UploadedProjects/<user id>
    export CODESIGN_ALLOCATE=/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/codesign_allocate
    export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin"
   
Signing Identity:     "iPhone Developer: Aniello Castellano (xxxx)"
Provisioning Profile: "Picchio Beach"
                      (xxxx)

    /usr/bin/codesign --force --sign 8587365041E211BA3C2FAB310098D58F7611A440 --keychain <user id> --entitlements /Users/administrator/Documents/UploadedProjects/<user id>/build/B4iProject.build/Release-iphoneos/B4iProject.build/Picchio\ Beach.app.xcent --timestamp=none /Users/administrator/Documents/UploadedProjects/<user id>/Payload/Picchio\ Beach.app
8587365041E211BA3C2FAB310098D58F7611A440: no identity found
Command /usr/bin/codesign failed with exit code 1


Error: ** BUILD FAILED **


The following build commands failed:
    CodeSign Payload/Picchio\ Beach.app
(1 failure)
Any idea?
 

netkomm

Active Member
Licensed User
Why do you need to switch the certificate? Does it start working after a few hours?
yes it does. but I don't understand what causes it and if it's just "normal" to wait for it to work again...
 

netkomm

Active Member
Licensed User
no. last night was working. Today (first time using) with the same settings (just added the icons for final release) and the problem arises. Same certificates, no change.
 
Top