iOS Question Troubles to compile IOS apps

umberto_dev2

Member
Licensed User
Hello,
I'm trying to compile an app (i'm using Erel's iBeacon example). When I compile I receive several error messages like:

B4i line: 41
Log(\
no visible @interface for 'B4ICommon' declares the selector 'LogImpl:::'

Out: Build settings from command line:
ARCHS = arm64
CODE_SIGN_IDENTITY = iPhone Distribution: xxxxxxxxxx (UXTxxxxxxx)
CONFIGURATION_BUILD_DIR = /Users/xxxxxxx/Downloads/B4iBS/UploadedProjects/<user id>/Payload
OTHER_CODE_SIGN_FLAGS = --keychain <user id>
PRODUCT_NAME = B4i Example
PROVISIONING_PROFILE = xxxxxxx-xxxxx-xxxxx-xxxxx-xxxxxxxx

=== BUILD TARGET B4iProject OF PROJECT B4iProject WITH CONFIGURATION Release ===

Check dependencies

[self->___c LogImpl:mad:"7131074" :mad:"Not authorized" :0];
~~~~~~~~~~ ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/Users/xxxxx/Documents/B4iBuildServer/UploadedProjects/<user id>/B4iProject/b4i_main.m:156:13: error: no visible @interface for 'B4ICommon' declares the selector 'LogImpl:::'

It happens both on Sierra and Mojave (on different machines)
Xcode 9.2 on Sierra and 10.0 on Mojave
Build server is 5.30

I created a new Bridge and it ran smoothly.

Any idea how to fix that?
Thank you
 

umberto_dev2

Member
Licensed User
Hello. It' Erel's ibeacon code. I just changed the beacon ID. Last year it was running smoothly. Maybe it's something that changed on the libraries.

Private Sub LocManager_AuthorizationStatusChanged (Status As Int)
If Not(LocManager.IsAuthorized Or LocManager.AuthorizationStatus = LocManager.AUTHORIZATION_NOT_DETERMINED) Then
Log("Not authorized")
btnStart.Enabled = False
End If
End Sub
The line in blue is the 41st.
 

umberto_dev2

Member
Licensed User
Ok. Erel. Thank you. I supposed it was a problem with different releases. But I have one more silly question, since I'm not working on B4I since last year: where do I find the new build server? I looked at the b4i home page but I don't remember where I should look for it. Maybe in one of your emails with upgrades?
 
Top