Android Question Unable to connect my FTP server on Vodafone network!

Discussion in 'Android Questions' started by tigrot, May 22, 2015.

  1. tigrot

    tigrot Well-Known Member Licensed User

    Hi Everybody,
    I have this strange issue: I have an APP comunicating via FTPS to my webserver. Everything is ok if I play with transfer via cabled network(XDSL), if I connect via Vodafone UMTS(or LTE) network the AUTH command seems to be the last thing received by IIS FTP server. Tested from another FTP APP the issue seems the same on the same network.
    I must remember i use Explicit FTP over TLS.
    The command source is :
    Code:
    FTP.Initialize("FTP","www.xxxxxx.it",21,"YYYYYY","ZZZZZZZZZZZ")
      
    FTP.PassiveMode=True
      
    FTP.UseSSL=False
      
    FTP.SetCustomSSLTrustManager(managerx)
      
    FTP.UseSSLExplicit=True
    Does anybody know the solution?

    Best regards
    Mauro Zanin
     
  2. giga

    giga Well-Known Member Licensed User

    Do you have an error generated or is it just slow?
     
  3. tigrot

    tigrot Well-Known Member Licensed User

    No it seems to do anything(the sequence of events seems to break). On server's log there is only CONNECT- AUTH - DISCONNECT
    I've read about this issue, but never had the chance to see...

    Ciao
    Mauro
     
  4. giga

    giga Well-Known Member Licensed User

    Just a thought. Do you think this could be a timeout issue or a provider port restriction problem?
     
    tigrot likes this.
  5. tigrot

    tigrot Well-Known Member Licensed User

    Hi Giga,
    for sure I have traced the issue. I get connection, send AUTH message, then the server waits indefinitelly for TSL handshake. I have tested many clients and I get the same. Maybe there is a filter on this port. The strange is that AUTH message passes! I'm trying to implement SFTP but B4A implementation is very poor. At present I'm unable to use it, the server states "Unknown protocol". I've tested the SFTP server using some commercial clients and it works very well.
    Since I love to write original protocols. I'll create one just for added security.
    Thank you to care about my problems! And have a nice week...
    Mauro
     
    giga likes this.
  6. giga

    giga Well-Known Member Licensed User

    Your Welcome. :)
     
  7. tigrot

    tigrot Well-Known Member Licensed User

    Just to explain the issue: I had to disable Kerberos protocols on server, so I was able to transfer. Thanks again!
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice