Android Question Uncaught translation error: java.util.concurrent.ExecutionException: java.lang.OutOfMemoryError: Jav

Similar threads

B4A Question Firebase Firestore
B4A Tutorial MJPEG / CCTV Server
B4A Question [ SOLVED ] Compiling big app
B4A Tutorial Uncaught Exceptions
B4A Code Snippet Advertising id

rafaelmotaquintana

Active Member
Licensed User
Convert byte code - dex. Error
Uncaught translation error: java.util.concurrent.ExecutionException: java.lang.OutOfMemoryError: Java heap space
1 error; aborting



This error shows after I upgrade the manifest line

<uses-sdk android:minSdkVersion="5" android:targetSdkVersion="26"/>

to

<uses-sdk android:minSdkVersion="5" android:targetSdkVersion="28"/>

I downloaded the recommended 28 versions, and changed the paths
Android.jar = C:\android\platforms\android-28\android.jar

Also changed this line in file B4XV5.INI

MaxRamForDex=1024

Using Windows 7 32bits, 4GB Ram.
I don't know what else to do. I have read that using 64bits
 

Pendrush

Well-Known Member
Licensed User
You need 64bit windows and JDK x64 or OpenJDK, to be able to set MaxRamForDex=2048 or MaxRamForDex=3096.
 

rafaelmotaquintana

Active Member
Licensed User
I installed the system in Windows 2016 Server 64bits.
Everything fine, but have this problem.
When trying to open SDK MANAGER, I Got this error, and suggested items to install does not appears

c:\Users\Administrator\AppData\Local\Temp\1 (Access is denied)

I don't know if I have to open another thread for this, sorry.

Thanks in advance
 

Erel

Administrator
Staff member
Licensed User
Start with the "ready to run" SDK: https://www.b4x.com/android/forum/threads/99780/#content

The error means that the default temp folder is not accessible. You can try to run B4A as an administrator. It might help. Another option is to run the sdk manager from B4J and change the temp folder. It is a simple change.
 

rafaelmotaquintana

Active Member
Licensed User
I tried opening B4A as administrator. Same result.
I'll use the ready to run Sdk. If not, then I will download B4J and change the temp folder.
Thanks
 
Top