Android Question Urgent - Can't install anything with any way.

Discussion in 'Android Questions' started by hatzisn, May 9, 2019.

  1. hatzisn

    hatzisn Active Member Licensed User

    Dear all,

    I am facing a problem. I can't install anything in B4A 9.00.
    I get the following error:

    Code:
    B4A Version: 9.00
    Parsing code.    (
    0.06s)
    Building folders structure.    (
    0.19s)
    Compiling code.    (
    0.07s)
     
    ObfuscatorMap.txt 
    file created in Objects folder.
    Compiling layouts code.    (
    0.01s)
    Organizing libraries.    (
    0.02s)
    Generating R 
    file.    (0.80s)
    Compiling generated Java code.    (
    3.01s)
    Convert byte code - optimized dex.    (
    10.79s)
        Optimized dexer failed. Switching 
    to Standard dexer.
    Packaging files.    (
    1.77s)
    Copying libraries resources    (
    0.06s)
        Found 
    8 resource files.
    Signing package 
    file (private key).    (2.15s)
    ZipAlign 
    file.    (0.24s)
    Installing 
    file to device.    Error
    The system cannot find the 
    file specified
    What I did is that I downloaded the SDKManager 3.35 and installed with it what was suggested. Tried to check the creation of a wear OS emulator - got an error saying Device definition not found: Wear OS Square - as seen in following image (I had installed the wear OS image) and tried to install the china wear OS image also to see if it will work. It didn't.

    upload_2019-5-9_15-22-56.png

    This might not be the case though. What I did next was to create a program to check if my phone has been hacked because I would like to check if notifications are automatically deleted. So I created a program with notification listener and TTS to speak notifications to me and tried to install it. Immediately my computer started to go nuts and the hard disk started to work continuously and I was unable to install it. I pressed the compile though and the process timed out (3 times that I tried). I decided to wait for my hard disk to calm and when I tried to install the program it seemed that the program was installed (but it did not function as expected) but I never got the message of successful installation from B4A. I tried again and again and B4A has stack in the installing to device and timed out all the times. I rebooted the phone and the same thing happened. I rebooted also my computer and since then I get all the times the previous message in code part.

    What may have gone wrong? Wicked phone, wicked computer or totally wicked hackers that do not deserve to be called humans?

    Thanks


    Edit: I also tried with B4A Bridge - no luck
     
    Last edited: May 9, 2019
  2. kisoft

    kisoft Active Member Licensed User

  3. hatzisn

    hatzisn Active Member Licensed User

    I still have no luck. I deleted the SDK totally and reinstalled it but no luck.
     
  4. kisoft

    kisoft Active Member Licensed User

    Uninstall everything again. B4A also uninstall. Clear registry entries and install everything again. Preferably using this program :https://www.revouninstaller.com/. If that does not help, reinstall windows
     
  5. KMatle

    KMatle Expert Licensed User

    It's just a file. Try to check which one it is (admin rights?). No need to reinstall Windows :D
     
    mangojack likes this.
  6. DonManfred

    DonManfred Expert Licensed User

    Sounds like you did not setup your SDK correctly. Or you did not configured the IDE correctly to use the new one.

    You can find the Setup-Instructions here. https://www.b4x.com/b4a.html
    You also can watch this Video as it describes it clearly.


    Start with a new Blank folder like you see in the Video.

    Alternatively you can use the ReadyToRunSDK
     
    Last edited: May 10, 2019
    Erel likes this.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice