1. *** New version of B4J is available ***
    B4J v7.8
    Dismiss Notice

Android Question X App not installed.

Discussion in 'Android Questions' started by nypaulie, Apr 22, 2019.

  1. nypaulie

    nypaulie Active Member Licensed User

    [SOLVED - see below] Anyone ever get this error when doing compile/run? I even tried installing from the .apk file created and get the same error. I have no problems ordinarily (using the bridge).
    Note: Solved by agraham in the following post.
     
    Last edited: Apr 22, 2019
  2. agraham

    agraham Expert Licensed User

    Are you installing over an existing app? Try uninstalling the app first and see if it succeeds then. I get this rather unhelpful error if the version number of the app being installed is lower than that of the already installed app. Note that it is the package name in the build configuration that identifies the app, not the contents of #ApplicationLabel: in the project attributes.
     
  3. nypaulie

    nypaulie Active Member Licensed User

    THANK YOU! that did it - uninstalled and re-installed from .apk and it worked. You have saved me a ton of work. I'll try to do a compile/run next. thanks again.
    [Added Later] - subsequent compile/runs give no error... I no longer have to uninstall before each compile/run so I'm home free!
     
    Last edited: Apr 24, 2019
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice