iOS Question XCode 11 error

ilan

Expert
Licensed User
hi

after updating xcode 11 i have trouble running my apps. i use the latest b4i and b4i buildere a local mac.
is there something special i have to do?

error:
The following build commands failed:
CompileC /Users/ilantetruashvili/Downloads/macserver61/UploadedProjects/<user id>/build/B4iProject.build/Release-iphonesimulator/B4iProject.build/Objects-normal/x86_64/b4i_httputils2service.o /Users/ilantetruashvili/Downloads/macserver61/UploadedProjects/<user id>/B4iProject/b4i_httputils2service.m normal x86_64 objective-c com.apple.compilers.llvm.clang.1_0.compiler
(1 failure)
i have already included the Attribute: #PlistExtra: <key>UIUserInterfaceStyle</key><string>Light</string>

but still no luck :(
 

Semen Matusovskiy

Well-Known Member
Licensed User
An error is not here. I see the same

Error: ** BUILD FAILED **
The following build commands failed:
CompileC /Users/semenmatusovskiy/Downloads/B4iBuildServer/UploadedProjects/<user id>/build/B4iProject.build/Release-iphonesimulator/B4iProject.build/Objects-normal/x86_64/b4i_main.o /Users/semenmatusovskiy/Downloads/B4iBuildServer/UploadedProjects/<user id>/B4iProject/b4i_main.m normal x86_64 objective-c com.apple.compilers.llvm.clang.1_0.compiler
(1 failure)
at the bottom.

But real mistake (in my OBJC code) is written in the middle of the log
W = X;
^
/Users/semenmatusovskiy/Downloads/B4iBuildServer/UploadedProjects/<user id>/B4iProject/b4i_main.m:120:8: error: use of undeclared identifier 'X'
W = X;
 

ilan

Expert
Licensed User
Upload the full compilation logs as a text file.
ok, i have included 2 files. 1 is compiled to my Iphone 11 and 1 to Mac Simulator.

thanx, ilan
 

Attachments

Last edited:

ilan

Expert
Licensed User
This is the relevant error:
Build input file cannot be found: '/Users/ilantetruashvili/Downloads/macserver61/UploadedProjects/<user id>/B4iProject/b4i_httpjob.m'

Try to change the user id in the build server settings. Does it make any difference?
yes, erel it worked. I changed the userid to "ilan" and now it works. the user id I used was the id for the hosted builder. I have also purchased the hosted builder package so I can also use b4i when I am not at home.

I have please 2 questions:

1, why is the userid important? (it worked before when I had Xcode 10)

2, how are you encounter the issue from the logs? can you write a thread about it so we can find the problem by ourselves? the error log that b4i gives us is very complicated to understand.

thank you, ilan
(ps: A happy new year with a lot of success, health, and happiness to you and your family :) and Gmar Hatima Tova)
 

Erel

Administrator
Staff member
Licensed User
A happy new year with a lot of success, health, and happiness to you and your family :) and Gmar Hatima Tova
Thank you Ilan. I wish the same for you and your family.

It is not really possible to find this issue from the logs. The problem is related to the files on the Mac not being updated. I'm not sure why they failed to update however by changing the user id you actually changed the folder as a workaround.
 
Top