iOS Question Xcode couldn't find any provisioning profiles


Well-Known Member
Licensed User
Longtime User

I am using B4i 4.81 on my Windows 10 PC running on my Mac as a VM.

I am using the local B4i Build Server 4.6 on my MacBook Pro Running MacOS 10.13.4.

My xCode is running 9.3

I have followed the tutorials on creating the certificates etc but when I try and install the B4i Bridge it fails.

B4i Version: 4.81
Parsing code. (0.00s)
Compiling code. (0.03s)
Building designer app. (0.00s)
Building Xcode project (0.42s)
Sending data to remote compiler. Error
Out: Build settings from command line:
ARCHS = armv7 arm64
CODE_SIGN_IDENTITY = iPhone Distribution: xxxxxxxxxxxxxxxxxx
CONFIGURATION_BUILD_DIR = /Users/AaronMacPro/Desktop/macserver/UploadedProjects/<user id>/Payload
OTHER_CODE_SIGN_FLAGS = --keychain <user id>
PROVISIONING_PROFILE = 99d52011-a3ea-475c-ada2-1bd692c5e7bf


Check dependencies
Code Signing Error: No profile matching '99d52011-a3ea-475c-ada2-1bd692c5e7bf' found: Xcode couldn't find any provisioning profiles matching '99d52011-a3ea-475c-ada2-1bd692c5e7bf'. Install the profile (by dragging and dropping it onto Xcode's dock item) or select a different one in the General tab of the target editor.
Code Signing Error: Code signing is required for product type 'Application' in SDK 'iOS 11.3'

Error: ** BUILD FAILED **

The following build commands failed:
Check dependencies
(1 failure)

I did come across this thread which has similar issue as me:

I tried to download XCode 9.2 from but when I click on the download link it comes up with 502 Bad Gateway when I click on the Xcode 9.2.xip file.

Seems that I can't roll back to version 9.2.

Any news on when the next update of B4i will be out to fix this or know how to install Xcode 9.2 in the mean time ?


Well-Known Member
Licensed User
Longtime User
Might be a temporary problem in their site.
Just tried again now and it let me download the file.

I downloaded the file and then it opened xCode and it shows that it's version 9.2. When I run xCode from the lanuchpad it shows 9.3.

When I compile the B4i-Bridge it still shows the same error as per post 1.

How do you tell B4i to use xCode 9.2 ?
Upvote 0


Well-Known Member
Licensed User
Longtime User
B4i builder will use the default version
I had a look at xCode and found the following which I didn't have to restart the builder..

- Opened xCode from the launchpad.
- Clicked on xCode > Preferences from the menu.
- Selected the 'Locations' tab.
- Changed 'Command Line Tools' to xCode 9.2

Then in B4i I just complied like normal and it worked.
Upvote 0


Well-Known Member
Licensed User
Longtime User
I'm stuck with this problem. I downgraded to Xcode 9.2 then 9.0 but no change. I did manage to compile my app but when uploading I get this error. The provision file is definitely a distribution type as its installed and working on my devices.



Erel, could I try the remote builder, temporarily, to see if I can work this out?

Last edited:
Upvote 0