B4J Question [ABM for dummies] real dummies :) startup question.

Marc Van Cauwenberghe

Member
Licensed User
Hi,

first of all thanks again for B4X and all the people who worked, helped debugged, etc.. it and the extra libraies, examples, etc...
I am now trying ABmaterial now. Trying everything that I can get my hands on...
As was suggested I started the lessons by Harris
You MUST be using ABMaterial 4.03 and B4J 5.90 (minimum).
1) Where can I get 'ABMaterial 4.03', should it be 4.03 or will the latest 4.30 also be OK?

In the Template folder, double click on the Template.b4j file to open the project in B4J.
Compile the app.
2) I open the project and it says: libraries missing. Should I place some extra libraries in the some folder?

Talk about dummies....


Best regards,
Marc
 

Harris

Expert
Licensed User
Versions above 4.03 should work... Haven't tested it on the tut...

What libs are missing? ABMaterial perhaps?

Thanks
 

Harris

Expert
Licensed User
I just opened the Template with B4J 6.01.... It said ABMaterial library not found....

Then I opened the same using B4J 7.31 (which I upgraded to last week).
I adjusted my additional folder structures according to Erels suggestion for B4X compatibility.

Template project opened just fine with no issues... since ABM jar is in the additional libs folder.

Good luck - and enjoy ABM.
 

Marc Van Cauwenberghe

Member
Licensed User
Hi,

thank you.
Point 1: is ok then.
Point 2:
I am using 7.31, still not ok.
Template project opened just fine with no issues... since ABM jar is in the additional libs folder.
Still showing up an error. :(
And no, the ABM jar is not in the additional libs folder.

... much later ...

What I had to do was copy the ABMaterial4.30.jar file (I also copied the ABMaterial4.30.xml, but do not know if this is needed)
from
ABMaterial4.30\Library
to
B4X\AdditionalLibraries\B4J

The library then showed up in the B4J IDE so that one can enable it.

Running it gives:

upload_2019-3-31_10-18-30.png


Me thinks we need a idiot proof setup :)

Any help?

I will persevere till the end.

Have a nice sun day everyone.

Best regards,
Marc
 

alwaysbusy

Expert
Licensed User
Installing a B4J library is basic B4J stuff, not basic ABM. It is the same for every library in B4X. You must copy ALL the jar and xml files from the library folder to your B4J library folder.

If you are really new to B4X in general, you may want to go through the B4X booklets first before tackling a big one as ABM: https://www.b4x.com/android/forum/threads/b4x-documentation-booklets.88985/

As for the error line, this is probably an incompatibility between ABM versions. You can comment out this line.
 

Marc Van Cauwenberghe

Member
Licensed User
Hi Alain,

seem to be getting interest from the big boss :)
Thank you for the hints.
I have looked at booklets and did not see anything related to the handling of projects and there libraries, but I could be wrong and overlooked it.
But nevermind we are getting closser.
As to you hint, I copied all jar and xml from the ABMaterial4.30\Library to my D:\Development\B4X\AdditionalLibraries\B4J
The Compile seems to be OK :
upload_2019-3-31_14-10-18.png

So far so good.
The log life on top gives some warnings that (see above) but I do not think this should be a problem.

Waiting for debugger to connect...
Program started.
Start B4J Analyse!
When an error occurs, check the B4JAnalyse.log file in the Objects folder to see the last B4J line it was working on.
Collecting data from B4J source files... (1/2)
ABMShared.bas
DBM.bas
ABMCacheControl.bas
ABMErrorHandler.bas
ABMRootFilter.bas
ABMCacheScavenger.bas
ABMPageTemplate.bas
AboutPage.bas
ABMApplication.bas
Template.b4j
Analysing data from B4J source files... (2/2)
loading D:\DEVELO~1\B4X\B4J\ABMaterialForDummies\Template\Objects: copymewithjar.needs...
Using cache system: 3.0
Needs material/awesome icons
Building D:\DEVELO~1\B4X\B4J\ABMaterialForDummies\Template\Objects\copymewithjar.js.needs
Building core.min.1554034188031.css...
2019-03-31 14:09:48.617:INFO::main: Logging initialized @6557ms to org.eclipse.jetty.util.log.StdErrLog
2019-03-31 14:09:48.786:INFO:eek:ejs.Server:main: jetty-9.4.z-SNAPSHOT; built: 2018-05-03T15:56:21.710Z; git: daa59876e6f384329b122929e70a80934569428c; jvm 1.8.0_202-b08
2019-03-31 14:09:48.856:INFO:eek:ejs.session:main: DefaultSessionIdManager workerName=node0
2019-03-31 14:09:48.856:INFO:eek:ejs.session:main: No SessionScavenger set, using defaults
2019-03-31 14:09:48.859:INFO:eek:ejs.session:main: node0 Scavenging every 600000ms
2019-03-31 14:09:48.887:INFO:eek:ejsh.ContextHandler:main: Started o.e.j.s.ServletContextHandler@3d921e20{/,file:///D:/Development/B4X/B4J/ABMaterialForDummies/Template/Objects/www/,AVAILABLE}
2019-03-31 14:09:48.890:INFO:eek:ejs.AbstractNCSARequestLog:main: Opened D:\Development\B4X\B4J\ABMaterialForDummies\Template\Objects\logs\b4j-2019_03_31.request.log
2019-03-31 14:09:49.530:INFO:eek:ejs.AbstractConnector:main: Started ServerConnector@33173534{HTTP/1.1,[http/1.1]}{0.0.0.0:51045}
2019-03-31 14:09:49.531:INFO:eek:ejs.Server:main: Started @7472ms
Emulated network latency: 100ms
2019-03-31 14:09:51.313:INFO:eek:ejs.AbstractConnector:main: Stopped ServerConnector@33173534{HTTP/1.1,[http/1.1]}{0.0.0.0:51045}
2019-03-31 14:09:51.314:INFO:eek:ejs.session:main: node0 Stopped scavenging
2019-03-31 14:09:51.317:INFO:eek:ejsh.ContextHandler:main: Stopped o.e.j.s.ServletContextHandler@3d921e20{/,file:///D:/Development/B4X/B4J/ABMaterialForDummies/Template/Objects/www/,UNAVAILABLE}
2019-03-31 14:09:51.321:INFO:eek:ejs.Server:main: jetty-9.4.z-SNAPSHOT; built: 2018-05-03T15:56:21.710Z; git: daa59876e6f384329b122929e70a80934569428c; jvm 1.8.0_202-b08
2019-03-31 14:09:51.324:INFO:eek:ejsh.ContextHandler:main: Started o.e.j.s.ServletContextHandler@3d921e20{/,file:///D:/Development/B4X/B4J/ABMaterialForDummies/Template/Objects/www/,AVAILABLE}
2019-03-31 14:09:51.325:INFO:eek:ejs.AbstractNCSARequestLog:main: Opened D:\Development\B4X\B4J\ABMaterialForDummies\Template\Objects\logs\b4j-2019_03_31.request.log
2019-03-31 14:09:51.326:INFO:eek:ejs.session:main: DefaultSessionIdManager workerName=node0
2019-03-31 14:09:51.326:INFO:eek:ejs.session:main: No SessionScavenger set, using defaults
2019-03-31 14:09:51.326:INFO:eek:ejs.session:main: node0 Scavenging every 660000ms
2019-03-31 14:09:51.669:INFO:eek:ejs.AbstractConnector:main: Started ServerConnector@33173534{HTTP/1.1,[http/1.1]}{0.0.0.0:51045}
2019-03-31 14:09:51.669:INFO:eek:ejs.Server:main: Started @9614ms
2019-03-31 14:09:51.669:INFO:eek:ejs.session:main: node0 Scavenging every 900000ms
/css/materialize.4.26.min.css
Not Found
/js/core.4.30.min.js
Not Found
Some errors still exsist.

Looking at http://localhost:51045/template/ in my chrome browser gives me:
upload_2019-3-31_14-18-56.png

but this keeps on going and going...

I hope someone helps me out.

Many thanks.

Best regards,
Marc
 

alwaysbusy

Expert
Licensed User
If the dummies tutorials still use 4.03 (I haven't checked), then indeed you will need to replace its www\js, www\css and www\fonts folders with the ones for the version you use (e.g. the ones for 4.30).

Every version of ABM comes with a series of jar/xml files, and new versions of the javascript/css/font files. In a lot of cases they have not changed, but the .core ones will most likely have. (bug fixes can be in both the jar (java) and web files (js, css)). You can find this www in the library folder too.

Sorry I did not mention this :oops: These things seem so obvious for me after all these years I forget for a new user it may not be.

EDIT: Using the Chrome browser, pressing F5 and looking at the console log and network tab can be helpful to find such cases.
 

Harris

Expert
Licensed User
Just downloaded and compiled dummies template project (zip) from 2nd post (the project).

/favicon.ico - not found.... On first compile.
After second run, project loaded as expected. My ABMaterial (Version 4.03) - from libs tab.

These things seem so obvious for me after all these years I forget for a new user it may not be
Too true... even when one tries to explain the basics to a beginner.

Thanks
 
Top