About designer

Discussion in 'Questions (Windows Mobile)' started by JJM, Mar 17, 2008.

  1. JJM

    JJM Active Member Licensed User

    Hi,
    I have a bug when i trie to put image in a buttonimage (if this buttonimage is added in the designer of a preexisting file); i get : An error occured. Error loading image.
    If i create a new file and a new designer i have no problem.

    Help me!
    JJ M
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Can you write the steps required to see this problem?
     
  3. JJM

    JJM Active Member Licensed User

    Hi Erel,
    I just understand the bug: if you want to use an image which is in the same folder as the file sbp, you get an error because the designer tries to copy the image in the folder but this image is yet in the folder and is in used...

    JJ M
     
    Last edited: Mar 17, 2008
  4. Erel

    Erel Administrator Staff Member Licensed User

    It doesn't happen here.
    Anyone else sees this problem?
     
  5. klaus

    klaus Expert Licensed User

    Hello
    I tried it, on the desktop, and get the same error.

    Steps:
    1. new project
    2. saved the project in directory TestProject
    3. in the Designer, added an ImageButton to the form
    4. in the Designer, loaded an image from another directory Bitmaps
    5. the designer copies the image file to the TestProject directory
    6. in the Designer, added a second ImageButton
    7. tried to lo load the same Image file, as for the first ImageButton, from the Bitmap directory.
    in this case the error happens.

    for step 7. we must load the image file from the TestProject directory

    The error happens when we try to load an image file that already exists in the project directory from another directory.

    It would be nice, instead of getting an error, that the Designer checks if the image file already exists and changes the directory itself.

    Best regards

    Klaus
    Switzerland
     
  6. Erel

    Erel Administrator Staff Member Licensed User

    Thank you JJM and Klaus.
    It will be fixed in the next release.
     
Loading...