Android Question Add does not start anymore

johnmie

Active Member
Licensed User
Longtime User
I wonder why my app refuses to start. Since 2 (working) days I get this error in debug mode (and I am despairing!):
Logger connected to: 5203e8a2fc01b317
--------- beginning of crash
--------- beginning of main
--------- beginning of system
[IDE message - 3:13:50]
An error occurred.
Rapid Debugger failed to connect to process. Please try to run again.

and this in all recently developed apps.

Erel said we should first try in release mode, but trying in release mode was even worse:

but in release mode I get this during compilation
B4A Version: 12.50 BETA #1
Parsing code. (0.35s)
Java Version: 14
Building folders structure. (0.12s)
Running custom action. (0.09s)
Compiling code. (0.61s)
Compiling layouts code. (0.08s)
Organizing libraries. (0.00s)
(AndroidX SDK)
Compiling resources (0.07s)
Linking resources (0.48s)
Compiling generated Java code. (3.90s)
Finding libraries that need to be dexed. (0.01s)
Dex code (3.05s)
Dex merge (2.11s)
Copying libraries resources (0.56s)
ZipAlign file. (0.06s)
Signing package file (private key). (0.44s)
Installing file to device. (9.85s)
Device serial: 5203e8a2fc01b317
Completed successfully.


An then the program hangs forever and the logger does not even show a single word.

see also start error log (attached)

Just downloaded the latest B4A version 12.5 and modified manifest to TargetSDK 33 - no change.

I also read somewhere that one of the libraries could at fault. but how could I find out which library (if any) caused the problem?

1686576871875.png


Thanks in advance for your help,
john m.
 

Attachments

  • AllStartErrors.txt
    20.9 KB · Views: 48

JohnC

Expert
Licensed User
Longtime User
By default, the B4A IDE filters out most log events (in the "Logs" list) happening in the device and just displays the events associated with your app.

So, to get more clues on what is causing the crash when your app starts, try unchecking the "Filter" box on the "Logs" tab - this will then start to display ALL events on your device which can be a lot.

So, click the "Connect" button, then try to click the "Clear" button right before you try to start your app, then as soon as your app crashes, disconnect your device from the IDE - this will help prevent too many extra events from being added to the logs list after the crash so it will be easier to see the events around the crash.

Post the log events related just to when you tried starting your app and that will hopefully give us an idea of what might be the problem.
 
Upvote 0

johnmie

Active Member
Licensed User
Longtime User
attache please find two files with logs as per you suggestion:
1. CLVTree, a very small app that works perfectly
2. VitaCalc, the one that causes the problem (9 pages, 14070 lines of code including some no longer used ones)
I have no idea where to look for the start of the program and what to look for. I tried to run a previous version (2021) of this app
that I know it worked correctly at the time. bur had the same problem now.

I'd be very very grateful for any suggestion. Thanks a lot in advance,
john m.
 

Attachments

  • FILE CLVTREE.b4a.txt
    317.6 KB · Views: 39
  • FILE VitaCalc_8503.b4a.txt
    126.5 KB · Views: 44
Upvote 0

johnmie

Active Member
Licensed User
Longtime User
I just modified the build configuration renaming the package name etc.
Now the program starts at least but hangs after
Main Page:
Sub Activity_Create(FirstTime As Boolean)
    Log("creating in main page")
    Dim pm As B4XPagesManager
    pm.Initialize(Activity)
End Sub

wonder why?
 
Upvote 0
Top