Android Question App not installed

Discussion in 'Android Questions' started by geoffschultz, Feb 14, 2015.

  1. geoffschultz

    geoffschultz Member Licensed User

    I used an app called "AppMgr III" to see what would happen if someone moved my app to external storage. It didn't run after moving it. I tried removing it and reinstalling it, but it will no longer install. I get the message "App not installed" when trying to install it from the Play Store or from B4A-Bridge. I've tried changing all of the project attributes (ApplicationLabel, VersionCode, VersionName) without success. How can I undo whatever has been done?

    -- Geoff
     
  2. stevel05

    stevel05 Expert Licensed User

    Did you uninstall it using AppMgr III? It may be blocking the subsequent installs if not.

    To make it a different app as far as the OS is concerned, you need to change the package name, but that's a drastic last option.
    You could also try uninstalling AppMgr III.
     
  3. Cableguy

    Cableguy Expert Licensed User

    maybe a stupid question but, did you set "can instal to SD" to true?
     
  4. geoffschultz

    geoffschultz Member Licensed User

    I removed my app using the normal Android based method. I did not use AppMgr III. I tried uninstalling AppMgr III with no change in behavior.

    "Can install to SD" is set to be true.

    -- Geoff
     
  5. geoffschultz

    geoffschultz Member Licensed User

    Since this line of questioning isn't going too far, what can cause an "App not installed" message? What vestiges of the installation should I look for and where are they located?

    -- Geoff
     
  6. stevel05

    stevel05 Expert Licensed User

    Hi Geoff, it doesn't appear that this question has arisen before on the forum, so it's not surprising that no one can give you a quick answer. As it's a general Android issue (not B4a specific) you'll probably find the answer quicker by Googleing the problem. In fact doing that, there are half a dozen things to try on the first page of results.

    As I can't recreate the problem I can't try them out and give you a definitive answer, so give it a go and let us know how you get on.
     
  7. Erel

    Erel Administrator Staff Member Licensed User

    Try to set: #CanInstallToExternalStorage: False
     
  8. geoffschultz

    geoffschultz Member Licensed User

    I have tried everything that I could find through Google. Nothing solved it. Finally I did a factory reset and that solved the problem. I'm leaving on a 4 month trip to Panama/Colombia tomorrow where I'll have very limited Internet, so I figured that it would be less painful to re-install everything from here.

    Thanks for the suggestions. I'm keeping away from those types of apps in the future!

    -- Geoff
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice