Android Question App will not install on Genymotion

ilan

Expert
Licensed User
hi

I am trying to install my app on Genymotion and i get this error

'....
[ 88%] /data/local/tmp/MySalary_RAPID_DEBUG.apk
[ 90%] /data/local/tmp/MySalary_RAPID_DEBUG.apk
[ 93%] /data/local/tmp/MySalary_RAPID_DEBUG.apk
[ 95%] /data/local/tmp/MySalary_RAPID_DEBUG.apk
[ 97%] /data/local/tmp/MySalary_RAPID_DEBUG.apk
[100%] /data/local/tmp/MySalary_RAPID_DEBUG.apk
pkg: /data/local/tmp/MySalary_RAPID_DEBUG.apk
Failure [INSTALL_FAILED_NO_MATCHING_ABIS]

what can i do to be able to run it on an emulator?

thanx
 

ilan

Expert
Licensed User
Upvote 0

ilan

Expert
Licensed User
One of the libraries that you are using includes a native (so) library. It doesn't include an x86 library so you cannot use it with Genymotion.

Is it possible to know what lib it is?
 
Upvote 0

MaFu

Well-Known Member
Licensed User
Is it possible to know what lib it is?
Open your apk with a zip tool like WinZIP or 7Zip and have a look at the "lib" folder. The subfolders in "lib" contains the native libraries and the names corresponds to the cpu type (armeabi-v7a, x86, ...).
 
Upvote 0

DonManfred

Expert
Licensed User
Is it possible to know what lib it is?
Check all libs you are using in your project.
open the library jar (one for one) with a zip tool. Look if there is a lib folder with some subfolders.

Maybe we can help if you post a list of all used libraries....
 
Upvote 0

ilan

Expert
Licensed User
Check all libs you are using in your project.
open the library jar (one for one) with a zip tool. Look if there is a lib folder with some subfolders.

Maybe we can help if you post a list of all used libraries....


libs.png
 
Upvote 0

DonManfred

Expert
Licensed User
Probably DropboxSync? It is a old lib and it could be that there is a native.so involved.

Rename Dropboxsync.jar to Dropboxsync.jar.zip and open the zip. Is there a folder with native libs? If yes; is there a folder for X86 Architecture too?

Please note that Dropboxsync is officially deprecated. It uses V1 of the API which will be removed at some point at Dropbox.

To be congrete:
Timeline
  • June 28, 2016: API v1 is deprecated.
  • September 28, 2016: If you haven’t acknowledged the deprecation, new users of your app will see a warning when linking their Dropbox account.
  • June 28, 2017: If you haven’t acknowledged the deprecation, all users who have linked their Dropbox account to your app will receive a warning email.
  • September 28, 2017: API v1 endpoints are turned off.
This means that probably from Sept 29 you are not able to use DropboxSync anymore.

time to switch to an Alternative:
1. https://www.b4x.com/android/forum/t...-http-all-using-httputils2.56842/#post-357760
2. https://www.b4x.com/android/forum/threads/beta-dropbox-sdk-v2-java.74019/
 
Last edited:
Upvote 0

ilan

Expert
Licensed User
Upvote 0

MaFu

Well-Known Member
Licensed User
Too much effort to check each lib. Check your apk instead, the name of the missing native lib should reasonably correspond with the java lib.
If you found a lib that exists in the lib/armeabi-v7a folder and is missing in lib/x86 then this may the reason for the error.
 
Upvote 0
Top