iOS Question Apple id doesn't match bundle identifier

John Peat

Member
Licensed User
I have developed a new app and are trying to upload to Apple. In doing this I needed to fully understand bundles, apple id's, cert's and provisioning files.

The apps bundle identifier is 'VisitorRego.VRPassport'

upload_2016-4-14_5-48-22.png


It needs to be in this format 'name.name' - it can't be just 'name' or 'name.*'

So I create an Apple id using a wild card as I am using the hosted build server

upload_2016-4-14_5-55-53.png


I create the provisioning file, and build the app 'Tools; Build Server; Build B4i Bridge App'

upload_2016-4-14_5-59-52.png


Fantastic - then I run it....
upload_2016-4-14_6-3-21.png


OK so I think; I won't use a the 'wild card.*'. So create a new Apple id and provisioning file:

upload_2016-4-14_6-7-25.png


build the app 'Tools; Build Server; Build B4i Bridge App'

upload_2016-4-14_6-10-6.png


Now I am confused! I have managed to develop the app using the Bridge 'Great Fantastic!' but are struggling to release it to iTunes connect and it's all centered around these ids i.e. I need to get this working in development mode and understand the process before I have any hope of uploading into iTunes.

Any help much appreciated.
 

sorex

Expert
Licensed User
Longtime User
I guess your package name is missing an extra part since you used a wildcard that expects another (3rd) part in the identifier.

change the certificate wildcard to VisitorRego.*
 
Upvote 0

John Peat

Member
Licensed User
Thanks guys. Changed the bundle id just to '*' managed to build the app on the hosted server and then run it.

upload_2016-4-15_6-25-31.png



Now for releasing it to iTunes connect. I'll post the result.
 
Upvote 0

John Peat

Member
Licensed User
Releasing app to iTunes Connect....

Deleted the app from the iPhone.

I made a new keys directory an pointed the IDE to it:

upload_2016-4-15_6-35-10.png


Create a new 'Private Sign Key'

Create a new Distribution Certificate, download, and save to 'C:\Dev\B4i\Keys_Release'

upload_2016-4-15_6-39-16.png


Created a new Apple id...

upload_2016-4-15_6-45-39.png


Not sure that I needed to do this....(suspect not)

Created a new provisioning file, downloaded and saved to 'C:\Dev\B4i\Keys_Release'

upload_2016-4-15_6-50-9.png


OK - at this point in the process I have done all I need to do release to iTunes.

Back in the B4i IDE....

'Tools'; 'Build Server'; 'Build Release App'

upload_2016-4-15_6-53-0.png


'Tools'; 'Build Server'; 'Download Last Build'
upload_2016-4-15_6-55-17.png


'Tools'; 'Build Server'; 'Upload App to iTunes Connect' (cross fingers, and clench buttocks)

upload_2016-4-15_7-0-49.png


Aaaaagh!

upload_2016-4-15_7-4-5.png


OK - I'll go and see if I need to anything in iTunes Connect (suspect that this is where the issue is....)

......
 

Attachments

  • upload_2016-4-15_6-54-51.png
    upload_2016-4-15_6-54-51.png
    135.2 KB · Views: 218
Upvote 0

John Peat

Member
Licensed User
Yes - the issue is now in iTunes Connect....

upload_2016-4-15_7-19-35.png


But now I have issues with naming the bundle with the wild card '*'

OK - let me redo the process not using the wild card......
 
Upvote 0
Top