Android Question B4A 5.20 Cannot find paths

demasi

Active Member
Licensed User
Hello,
I don´t know if this is a bug, but
when testing B4A 5.20 I can´t complete building due to an error: My paths are configured correct. I just installed new version above old version. Old version, 5, was working ok.


B4A version: 5.20 BETA
Parsing code. (0.08s)
Compiling code. (0.38s)
Compiling layouts code. (0.00s)
Generating R file. (1.45s)
Compiling generated Java code. (3.42s)
Convert byte code - optimized dex. (3.00s)
Packaging files. (2.69s)
Copying libraries resources (0.02s)
Found 2 resource files.
Signing package file (debug key). (2.30s)
ZipAlign file. Error
Cannot find:
Please configure paths (Tools - Configure Paths).​


thank you
 

demasi

Active Member
Licensed User
I don´t have this folder in my sdk folder. I created but resulted the same.
Could it be the Java SDK?
It was working ok with the older version (5.0)
Windows 7

These are the paths I´m using:
C:\Program Files\Java\jdk1.6.0_27\bin\javac.exe
C:\Program Files (x86)\Android\android-sdk\platforms\android-14\android.jar
T:\Dropbox\b4a\_Libraries
T:\Dropbox\b4a\_SharedModules
 
Upvote 0

demasi

Active Member
Licensed User
Another info: I have installed Android studio. I don´t know if this was the cause of the problem, because I haven´t used B4A after this.
I changed back my B4A to 5.02 and now the problem occurs again, so the problem may be with my paths. I changed all one by one, but the problem is the same.
 
Upvote 0

demasi

Active Member
Licensed User
feedback:
After half day installing and uninstalling things, sdk, java, etc. it worked!
The problem was not with release 5.20 of B4A. It was only a bad coincidence, because I´ve installed Android Studio at almost the same time.
I suppose the problem was with the Android Studio installer overwriting something, and it used version 23 of the tools. I was using 14. But no matter I changed from 23 to 14 it wasn´t working. The build always stopped at ZIPALIGN. So I looked for zipalign utility and it was not there, no place. I copied zipalign from the version 23 to version 20 and it worked like a charm. So I downloaded the version 20 using sdk manager and it´s all ok.
Thank you for your help.
 
Upvote 0
Top