Android Question B4A-Bridge - can't connect to phone

Scotter

Active Member
Licensed User
Used to work fine. It's been a month or so. Haven't made any changes to B4A. Haven't even updated to 9.0 yet.
On 8.80. Just wanted to make small change to app and re
It IS possible something changed on my phone but I don't know what.
My home network DID change. But I made sure of:
(1) Computer and phone are on same WiFi network.
(2) Confirmed correct IP address of phone; 192.168.1.5.
(3) Tried rebooting both devices.
(4) Made sure B4A-Bridge app is latest version.
(5) Combed forums for answers and tried method I saw Erel suggest once to use Mobile's hotspot.
Ideas?
 

emexes

Well-Known Member
Licensed User
Coincidentally, I just used the hotspot mode last night, and can confirm that it does work (on my hardware, at least).

edit: but I am not connected to any other wifi network at same time

Was momentarily tripped up by network IP address being 192.168.43.* rather than the more usual 192.168.0.* or 192.168.1.*

Once laptop is connected by wifi to Android hotspot, I can ping the Android device (gateway = IP 192.168.43.1)

Give that a burl.

I am thinking that perhaps your home network has clamped down any non-standard port numbers, and perhaps that B4A-Bridge on port 6789 has been caught by that.
 
Top