Android Question B4A-Bridge intermittent connections

BierHops

New Member
Licensed User
Hardware:
HP 17by3x Laptop 32 gig RAM 4 core
Motorola One 5G Ace. phone running Android 10
Software:
Windows 10.0.19042
B4A-Bridge 2.62
B4A Version 11.0
Norton A/V + VPN

B4A is white listed on the firewall
B4A-Bridge has the needed permissions turned on and I allowed it read/write permissions for the SD Card

I made sure only one instance of B4A is running to solve the "dueling programs" issue another user was having but B4A and B4-Bridge still rapidly connects and fails. One other thing to note: this phone is a Google-Locked phone, meaning other file managers on my laptop can't access the phone's file tree. When plugged into my laptop, the phone will show on the directory tree, but when selected I'm shown an empty folder. I have to use Google Files to see pictures taken on my phone. Has anyone else come across a problem using a Google-Locked phone to develop on? At this point I'm leaning toward using my older LG V30 as my test phone and not wasting too much time on one that may just be an incompatible device. Thanks!
 

agraham

Expert
Licensed User
When plugged into my laptop, the phone will show on the directory tree, but when selected I'm shown an empty folder.
Check "Default USB Configuration" in Developer options. Some phones also have a notification shown when USB is connected to let you select the mode - though I have found it can be buggy on several devices. You want "File Transfer", "MTP" or something similar,
 
Upvote 0

BierHops

New Member
Licensed User
I don't find any configuration or Developer options for this Motorola so I'm guessing it's a wash for this phone. That's ok, my LG works great and the LG is running Android 9 so it's fairly up to date. I'll have to keep development in mind the next time I choose a phone. Thanks for the help, it kept me from pulling my hair out.
 
Upvote 0

DonManfred

Expert
Licensed User
I don't find any configuration or Developer options for this Motorola so I'm guessing it's a wash for this phone.
Did you clicked several times (7 or 8) on the BUILD INFO to enable Developer Options?

It´s a link about Samsung but should work on other devices too. Check it.
 
Upvote 0

BierHops

New Member
Licensed User
Did you clicked several times (7 or 8) on the BUILD INFO to enable Developer Options?

It´s a link about Samsung but should work on other devices too. Check it.
Thanks! That did it. I notice another item:
When I open B4A and no project is loaded, B4A-Bridge will connect and disconnect rapidly from my Moto Ace, I don't recall it doing that on my LG V30 but I could be wrong.
Once I have an app loaded (MyFirstApp in this case as I'm new to B4A) it will connect and stay connected. It will install and run the app just fine, so I don't see it as a bug per se, just a curiosity.
Thanks again. There's a DIY project I saw on "Explaining Computers" (YouTube) regarding monitoring moisture levels in soil with my raspberry pi and I'd like to use my phone as the head for the pi.
 
Upvote 0
Top