B4a_server Problem


Licensed User
Longtime User
I’ve been trying to get b4a_server to work on a server with little success. The server has no connection to the internet so I’ve had to work through a local connection to modify it. This is where I am to date.
1) I’ve installed the following on the server:
a) FastCGI 1.5(x86)RTW
b) Java™ SE Development Kit 7 Update 5
c) Java™ 7Update 5
d) Java FX 2.1.1
e) Java FX 2.1.1 SDK
f) MYSQL Server 5.0
g) PHP 5.2.17
2) At C:\Inetpub\wwwroot on the server I installed
a) b4aserver.jar
b) b4a_server.php
c) logo.jpg
d) iisstart
e) files
i) bwlogo.png
ii) logo.jpg
iii) logo.png
f) config
g) run
h) localstart
i) functest.php (my php test file)
j) test.php (showinfo())
3) I created several blank MySQL databases.

I've attached text files showing the contents of the b4a_server.php and config files on the server and the error log and zip file from the IDE.

When I run the program and press a button on the device it take about 30 seconds for the task to fail.

What's happening? I would appreciate any help anyone could give me.


  • config.txt
    597 bytes · Views: 264
  • b4a_server.txt
    1.9 KB · Views: 264
  • errors.txt
    838 bytes · Views: 251
  • zip 072012.zip
    13.4 KB · Views: 202


Licensed User
Longtime User
The dns of the Buffalo Wireless Router is set to

What else could be causing the problem?
Upvote 0


Licensed User
Longtime User
I believe Erel said in an earlier post that the database got wiped when the Java Server received the device's connection request, however, my database keeps building.

mysql> select * from b4a;
| server | ip | time |
| logistics | | 1344000928 |
| logistics | | 1344014850 |
| logisticsserver | | 1343828792 |
| logisticsserver | | 1344257740 |
| logisticsserver | | 1344259921 |
| logisticsserver | | 1343932492 |
| logisticsserver | | 1343828552 |
| logisticsserver | | 1343919529 |
8 rows in set (0.00 sec)


what do you think is going on there?

Thanks for all of your help!


  • sql2.txt
    725 bytes · Views: 205
Upvote 0


Licensed User
Longtime User
If I try to execute the executable jar file, this is what I get.

C:\Inetpub\wwwroot>java -jar b4aserver.jar
Invalid or corrupt jarfile b4aserver.jar


When I use a fresh copy of the jar file from a cd that I burned with B4aServer-desktop on 30-Jul-12, I get this.

C:\Program Files\Logistics>java -jar b4aserver.jar
Invalid or corrupt jarfile b4aserver.jar

C:\Program Files\Logistics>

I don't believe that the jar file is corrupt but that's what I get.

Thanks for your help!


  • jar_execution.txt
    238 bytes · Views: 181
Upvote 0


Licensed User
Longtime User
Getting there!


This morning I accessed the server and ran run.bat. Then I executed the same java command from the command prompt.

After I did that I ran the B4AServerExample on my Galaxy tablet. It worked perfectly.

I left both windows from launching the jar file open and captured the information. (See Attachments)

I rebooted both the server and my Galaxy and recompiled the B4AServerExample. The program again hung up trying to reconnect with the Galaxy.

I logged onto the server and ran run.bat. This time it worked. I logged off of the server and recompiled the program which worked.

What do you think the hang up is now?

I really appreciate all of your help!



  • starting b4a from batch file.txt
    1.8 KB · Views: 190
  • starting b4a from command promp.txt
    516 bytes · Views: 188
Upvote 0