b4aserver won't connect


Licensed User
Longtime User
I run the b4a server example http://www.b4x.com/forum/additional...l-updates/9679-b4aserver-files.html#post53630 from my device (which runs in a local network) as is and it does not connect to the server.
I made the modifications to the desktop php file, changed URL line to be:
(this is my desktop's ip)
I run the batch file - it runs and does not finish running (keeps blinking).
In the device program I changed to
B4AServer.Initialize("", ServerName, "Main")
I run it with and without bridge connection and the server does not connect when clicking any of the buttons.
The message is always success=false, and the reason - task cancelled.

I tried both win7 and xp desktops.

the log:
** Service (b4aserverservice) Start **
Server not connected. Calling board web service.
Error connecting: org.apache.http.conn.ConnectTimeoutException: Connect to / timed out
Connected = false
Task=1 completed. Success=false, Message=Task cancelled

Help ?
Last edited:


Licensed User
Longtime User
I agree, this shows that something is wrong.
Other php files are going well : the hello.php, the index.php , when they are called from the browser of a device, using , they do not return as text without action.

But the first problem is that I cannot run the batch file without errors. The first error is :
ip address should end with the port <> :
I tried to add the port but it is still the same.
Upvote 0