B4J Tutorial B4J Download and Install

ivanomonti

Well-Known Member
Licensed User
Thank

Install java 7.0.45 +
JavaFX Scene Builder 1.1
Build Information
Version: 1.1-b35, Changeset: 50e3d7cdf394
Date: 2013-08-27 10:45 +
B4J 1.00 Beta 1
Windows 7 pro - intel core i5-2400 3ghz

Perfect
 

Erel

Administrator
Staff member
Licensed User
Hi Erel, great job. Is it possible to use layouts designed in B4A?
No. The UI is based on JavaFX framework. It is a different framework.

Please do not post questions in this thread. Instead start a new thread in the B4J questions forum.
 

holdemadvantage

Active Member
Licensed User
No. The UI is based on JavaFX framework. It is a different framework.

Please do not post questions in this thread. Instead start a new thread in the B4J questions forum.
Sorry i didn't saw it ! Now i have a lot of night to spend with this new game :)
 

agraham

Expert
Licensed User
It might be a good idea to name the B4J beta exe with a version number so you can tell if you have the latest without downloading it.
 

zolive33

Member
Licensed User
Scene Builder is a Java app. It should run natively on Linux.
I understand Erel, but how B4J (with Wine) Can launch JavaFX for Linux? Currently B4J returns me error "No associated application. Make sure that JavaFX Scene Builder is installed correctly".

In Terminal command to run JavaFXSceneBuilder is :
/opt/JavaFXSceneBuilder1.1/JavaFXSceneBuilder1.1 JavaFXSceneBuilder1 <File.fxml>
 

icefairy333

Active Member
Licensed User
B4X:
Parsing code.                          0.04
Compiling code.                        0.12
Compiling generated Java code.          Error
javac 1.7.0
src\b4j\example\main.java:5: 错误: 程序包javafx.application不存在
public class main extends javafx.application.Application{
                                            ^
1 个错误
I got this error(first time I install them with:jdk+b4j+javafx then I got this,after this I reinstall the b4j not take effect.
help me please.
 

dexMilano

Active Member
Licensed User
I'd like to see B4J and B4A on linux too.
:-(

Is it possible?
I'm a linux user and I'm using a VM just for that.

dex
 

maleche

Member
Licensed User
Got my first program up and running!
I can run the .jar file on windows 8, window 7, but unable to run on a MAC (OS 10.6.8) due to the requirement of java 7 not compatible with this version of MAC OS.
Is there another work-around? Can I compile my code using an older Java version?
Thanks for such a great product!
 
Top