Bug? Bridge disconnects

Discussion in 'iOS Bugs & Wishlist' started by mrred128, Oct 6, 2016.

  1. mrred128

    mrred128 Active Member Licensed User

    When my B4i has an app source open and the iphone (4 v 7.1.2, 5s 10.1 beta) will randomly disconnect and then try to reconnect, sometimes successful / sometimes not. There is a fresh compile of the bridge app on the device.

    Sometimes the disconnect happens during an execution and the app and bridge on the phone needs to be forced closed.


    For a quick test, I open and android source and connected a tablet. While the iphone was having issues, the tablet was not.

    B4i:2.80
    B4a:6.30
    Host is Windows 10 Anniversary / pro
    Java jdk1.8.0_65 on both
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    For what it worth, it doesn't happen here. The connection doesn't break.

    Intermittent network problems will break the debugger. It cannot reconnect.
     
  3. mrred128

    mrred128 Active Member Licensed User

    Why on the iphone and not the android? My access point is only 20 ft away.
     
  4. Erel

    Erel Administrator Staff Member Licensed User

    Are you sure that the Android device doesn't reconnect from time to time?
     
    Last edited: Oct 7, 2016
  5. mrred128

    mrred128 Active Member Licensed User

    On the iPhone it shows with a spinner and can take some time before it reconnects - like it's totally out of sync. I can only deduce from the android that everything is ok because the designer output is functional....ie: I am able to move the objects around.

    Aside from that, there is not much exposed from your programs for information.
     
  6. Erel

    Erel Administrator Staff Member Licensed User

    You need to test it in a different network.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice