iOS Question BUILD FAILED - B4A -> B4i

Discussion in 'iOS Questions' started by Radisk3, Oct 14, 2018 at 4:32 AM.

  1. Radisk3

    Radisk3 Member Licensed User

    Hello,

    I'm migrating a project from B4A to B4i.
    Became compatible all the code.
    At least without errors.
    However, at the time of the compile in B4i, appears the error attachment.
    I spent the day between searches on the forum, and adjustments to code and could not solve.
    Can someone help me?

    Link of the build procedure
    https://mega.nz/#!XC4WiIhT!WhBDsEpCHbQa2d8SpGo8S1H9Sgd2sYkUa9PU-_gf86M
     

    Attached Files:

  2. Erel

    Erel Administrator Staff Member Licensed User

    1. It is important to correct the warnings about invalid code in Globals subs.
    2. Why aren't you using xCustomListView library?
    3. What is servicoamf ?
     
  3. Radisk3

    Radisk3 Member Licensed User

    1. I agree.
    I am working on warnings.

    2. Because I found more practical to use the class CustomListView.
    I'll change and adapt to check.

    3. servicoamf came migrated from B4A. Are the services.
    Reajustei the code in the services to operate as classes in B4i and Services in B4A.

    Have something to suggest?
    Want to see the full code?
     
  4. Radisk3

    Radisk3 Member Licensed User

    Hello Erel,

    I discovered the problem.
    Irritating to spend hours looking for something that I messed up.
    Sleep helped.
    I have reviewed the code and found in a class of service that was left out of the #If the #ExcludeFromLibrary: True

    Thanks for the help.
    Now is to resolve the other error that appeared when running on the device.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice