iOS Question BUILD FAILED (SOLVED by updating Library)

Discussion in 'iOS Questions' started by skrjabin, Jul 22, 2019.

  1. skrjabin

    skrjabin Active Member Licensed User

    After not working with B4i for longer time (only B4A) I get this error when debugging or Building Release App. I use the hosted builderThe code of my app has not changed yet. It is the last version, that worked already.

    Code:
    B4i Version: 5.81
    Parsing code.    (
    0.08s)
    Building folders structure.    (
    0.31s)
    Compiling code.    (
    0.16s)
    Compiling layouts code.    (
    0.01s)
    Building Xcode project    (
    0.23s)
    Sending data 
    to remote compiler.    Error
    Out: Build 
    settings from command line:
        ARCHS = armv7 arm64

    ...

    note: Using new build system
    note: Planning build
    note: Constructing build description

    ...


    Error: ** BUILD FAILED **


    The following build commands failed:
        Ld /Users/administrator/Documents/UploadedProjects/<user 
    id>/build/B4iProject.build/Release-iphoneos/B4iProject.build/Objects-normal/armv7/AppAssionato normal armv7
    (
    1 failure)
    Did I miss to update something like B4i-Bridge?
     
  2. skrjabin

    skrjabin Active Member Licensed User

    I checked with a small testproject and it worked. So the problem seems to be somewhere in the code of my project? In some of the libraries? So the screenshot shows the libs, I use in this project.
     

    Attached Files:

  3. skrjabin

    skrjabin Active Member Licensed User

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice