Android Question Changing Package Name

ashton293

Member
Licensed User
This is becoming a very frustrating problem.

I am trying to establish a new app to replace an app that I couldn't update on the Google Play Store because of a different signing certificate.

The problem I NOW have is that each time I try to load the new app on the Play Store I am told the package name "b4a.example" already exists.

I check the android manifest file and note that the first mention of package is described as "b4a.example".

I have tried to change the package to b4a.test using "SetManifestAttribute(package, "b4a.test")" then try to compile then I get an error message which says:

"Could not find a part of the path: C://.............Test\Objects\gen\b4a\example\R.java. "

[I have also tried to use the package name "test" in lieu of "b4a.test" with the same result]

This is obviously because the "example" subdirectory isn't changed to "test".

I have also tried AddReplacement("b4a.example", "b4a.test") and that too has not solved the issue for me.


I have attached a small test example so someone can try to resolve my problem.

I have gone back to the basic structure for the manifest editor and still have the same problem.

This must have a simple solution but I can't see it.

Your help would be appreciated.

Thank you.
 

Attachments

Top