Compiled program won't run

djmrozinski

Member
Licensed User
I have gone through the sets and written some code, compiled and created a setup. I included all the libraries that I think I need.

Installed to the PPC and when I execute the EXE, I get the error message

"Can not find "myfilename" (or one of its components) Make sure the path adn filename are correct and all the required libraries are available.

Any suggestions?????

Thanks
Dave
 

djmrozinski

Member
Licensed User
The file name is test.exe It is a simple GPS application that I am doing to get familiar with basic4ppc

I have included serial2.dll and gps.dll and they both copied to the application folder during the install.

It seems like I need some other libraries. I do have a save dialog, does that require a different library?

Thanks
Dave
 

djmrozinski

Member
Licensed User
Attached are the files that I included in the CAB file. I also include the file test.shp for your review. I didn't include that file in the CAB.

Ran ok on the desktop.

Thanks for the help. This is my first attempt at PPC programming.

Dave
 

djmrozinski

Member
Licensed User
I will check that out. I thought I had updated but it makes sense. I am really enjoying working with Basic4PPC.

I got up to speed and running in short order.

Thanks
Dave
 

klaus

Expert
Licensed User
Hi djmrozinski
I tried also your test.zip code.
Unzipped it, copied it to my Qtek9090 and it works without any problems.
What is 'myfilename' you are referening to in your first post, there is no such word in your code?

Klaus
Switzerland
 

djmrozinski

Member
Licensed User
How can I determine if I have Net 2.0 framework installed on the PPC. The reason I ask is that I thought I had done the upgrade, but I would like to check before I try again.

Thanks
Dave
 

djmrozinski

Member
Licensed User
Don't see it on the list. Bet that is the problem. Great support here. I think I will enjoy moving into the PPC program world.

Thanks
Dave
 
Top