B4R Question Compiling & deploying Ino project (Arduino Uno - COM5) Error


New Member
I have recently started using Arduino as a hardware solution for current projects I am involved in, and I have just started using B4R and I am excited to have found it. I have been programming for over 40 years and I have a preference for Basic and Assembler over all the other languages I use probably as they were 2 of the 3 first languages I learned, so this is exciting to move away from the C base Arduino IDE and to an IDE I love.
Now that I have finished dribbling, I will get to the problem. I have been trying to compile and load my UNO boards with a few programs using B4R and I keep having the same problem. It seems that for some reason that I am blind to, the programs complete compiling error free but the compiler won't, or can't, communicate with my boards. The error "Compiling & deploying Ino project (Arduino Uno - COM5) Error" and then the process starts a shutdown sequence. I have tried different boards from UNO's to NANO's and even a Mega2560, as well as different prorams from the Blinking LED code through to more complex programs, but the same error occurs every time, with the variation of which com port the board is on. I am at a loss as to why this is happening. The only thing I can think of is that I have screwed up, but I don't know. I should mention that all these same boards are working fine in the Arduino IDE.
Any help with this would be grwatly appreciated.

With Thanks,
Stuart (goldswan)


New Member
Moved to the questions forum.

Have you closed Arduino IDE before you compiled? Otherwise the port might be locked.
Hi tigrot. Yes I did close the Arduino IDE. Old programming habit of closing everything before coding, just to be on the safe side. Thanks
Upvote 0

Johan Schoeman

Licensed User
Longtime User
I have had a similar problem before. For what it might be worth, try.....


From the B4R IDE:
Tools -> Board Selector and then select "atmega328old". If I select "atmega328" I get a similar error as what you are getting. Selecting "atmega328old" makes the problem disappear....
Upvote 0