1. *** New version of B4J is available ***
    B4J v7.8
    Dismiss Notice

Android Question Creating a Wrapper from an Android Library

Discussion in 'Android Questions' started by Marcos Alves, Sep 11, 2019 at 10:18 PM.

  1. Marcos Alves

    Marcos Alves Active Member Licensed User

  2. DonManfred

    DonManfred Expert Licensed User

    i don´t know. It depends on an old AS Version. I think 2.x or so.
    Newest is AS 3.5+

    In fact you do not need AS to create a wrapper for B4A.
    It does work with Eclipse also.
    Or with Notepad++ plus SimpleLibraryCompiler
     
    Erel likes this.
  3. Marcos Alves

    Marcos Alves Active Member Licensed User

    Thanks @DonManfred ! Is there any tutorial about how to do this?
     
  4. DonManfred

    DonManfred Expert Licensed User

    You can find some developer questions here:
    https://www.b4x.com/android/forum/forums/libraries-developers-questions.32/

    As far as i know there is no tutorial. At least for a AAR. It all depends on the Lib and what the lib does/include in the aar.
    One can not write a all-knowing-tutorial.

    Note that you need to have java knowledge. My java-knowledge was zero when i started using B4A.
     
    jimmyF likes this.
  5. Marcos Alves

    Marcos Alves Active Member Licensed User

    Thanks @DonManfred . I have some java knowledge but the integration and conversion to B4A environment is still confuse for me... I'll study this forum section to clarify...

    Thanks!
     
  6. DonManfred

    DonManfred Expert Licensed User

    hard wo answer this as i don´t know which AAR (and what it does) you want to wrap/what the goal is.
     
  7. Marcos Alves

    Marcos Alves Active Member Licensed User

    Last edited: Sep 12, 2019 at 4:04 PM
  8. Jmu5667

    Jmu5667 Well-Known Member Licensed User

    Hi Marcos, have you stopped using ABTO VoIP SDK ?

    John.
     
  9. Marcos Alves

    Marcos Alves Active Member Licensed User

    Hello John,

    I'm in direct contact with abto team now because there is something in targetsdk28 that is raising an error in the library. As you know, targetsdk28 will be mandatory for google play starting at November/2019. So, I'm trying to fix it together with abto and searching for alternatives also.

    Let's see what will happen...
     
  10. DonManfred

    DonManfred Expert Licensed User

    The mizu-voip seems not to have any additional activities which makes it more complicated to wrap. I mean if they had additional activities.
    The library consist on only a few classes which does handle all.

    I guess the complicated task is to get an B4A example setup. Manifestchanges, Runtimepermission and so on.

    Looking at the example, the documentation of this library and the other one, the free one:
    - I suggest the commercial one. As of documentation i guess it should work with targetsdk 28. It is good documented.
     
  11. Jmu5667

    Jmu5667 Well-Known Member Licensed User

    Keep me posted please :)
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice