Android Question DSNavigationDrawer and B4A 10.7 Beta 3 error

asales

Well-Known Member
Licensed User
I use the DSNavigationDrawer from from DesignSupport lib.

It works fine in B4A 10.6, but I get this error when I tried to compile in B4A 10.7 Beta 3:
B4X:
main$ResumableSub_Activity_Createresume (java line: 604)
java.lang.NoSuchFieldError: No field navdrawer_layout of type I in class Lanywheresoftware/b4a/objects/R$layout; or its superclasses (declaration of 'anywheresoftware.b4a.objects.R$layout' appears in /data/app/br.com.myprofiles/base.apk)
    at de.amberhome.objects.NavigationDrawerWrapper.Initialize2(NavigationDrawerWrapper.java:74)
    at de.amberhome.objects.NavigationDrawerWrapper.Initialize(NavigationDrawerWrapper.java:61)
Any help to solved this problem are welcome.
Thanks in advance.
 

asales

Well-Known Member
Licensed User
I don't think that this library is compatible with AndroidX sdk.
Until B4A 10.6 it was compatible.
You should switch to B4XDrawer.
I have some customizations in this DSNavigationDrawer - like a better visual to the switch button, submenus and separators - that I couldn't see that how can do this, in a easy way, using B4XDrawer.

dsmenu1.jpg
 
Upvote 0

Peter Simpson

Expert
Licensed User
Can you share this example?
Thanks.

I believe that this is basically the same thing, but using the class
 
Upvote 0
Top