Android Question Error at installing via B4A Bridge

ThePuiu

Active Member
Licensed User
Hi,
I'we made minor changes to an older application that was previously installed on the device.

When I tried to send the application to the tablet I receive an error message. I uninstalled the old application and restarted the tablet but the error persists.
Can you help me with a tip?

LE:
Android version 5.0.2
Manifest: minSdkVersion="14" android:targetSdkVersion="19"
 

Attachments

ThePuiu

Active Member
Licensed User
set to 26 and change PackageName and get this error at compile:
B4A Version: 9.30
Java Version: 8
Parsing code. (0.07s)
Building folders structure. (0.05s)
Compiling code. Error
Error parsing manifest script:
Error parsing google-services.json:
Error parsing manifest script:
Error parsing json file. Make sure that the package name is correct.
 

DonManfred

Expert
Licensed User
set to 26 and change PackageName and get this error at compile
if you are using firebase then your packagename is bound in the json. You can not rename the packagename without creating a new project in firebase with this packagename.

- Rename the packagename back
-try to deinstall the app and try again.
 

ThePuiu

Active Member
Licensed User
not working...same error (first one). Need to change the project's name in Firebase as the last solution?
 

ThePuiu

Active Member
Licensed User
I'we made another project on Firebase with different package name (the new one). Change in B4A package name. And...same error (#1)!
In B4A is no error in Log. After compile:
B4A Version: 9.30
Java Version: 8
Parsing code. (0.06s)
Building folders structure. (0.02s)
Compiling code. (0.39s)
Compiling layouts code. (0.01s)
Organizing libraries. (0.00s)
(Android Support Library)
Generating R file. (0.00s)
Compiling debugger engine code. (0.01s)
Compiling generated Java code. (0.02s)
Convert byte code - optimized dex. (2.15s)
Packaging files. (0.81s)
Copying libraries resources (0.02s)
Found 25 resource files.
Signing package file (private key). (0.68s)
ZipAlign file. (0.03s)
Installing file to device. (0.04s)
Installing with B4A-Bridge.
Completed successfully.

On my new tablet, working fine.
 

ThePuiu

Active Member
Licensed User
B4X:
AddManifestText(
<uses-sdk android:minSdkVersion="14" android:targetSdkVersion="28"/>
<supports-screens android:largeScreens="true"
    android:normalScreens="true"
    android:smallScreens="true"
    android:anyDensity="true"/>)
AddManifestText(<uses-feature android:name="android.hardware.location.gps"/>)
AddPermission (android.permission.ACCESS_FINE_LOCATION)
AddPermission (android.permission.READ_PHONE_STATE)

AddPermission (android.permission.INTERNET)
AddPermission (android.permission.ACCESS_WIFI_STATE)
AddPermission (android.permission.ACCESS_NETWORK_STATE)

AddPermission(android.permission.REQUEST_INSTALL_PACKAGES)

SetApplicationAttribute(android:icon, "@drawable/icon")
SetApplicationAttribute(android:label, "$LABEL$")
'End of default text.
AddApplicationText(
<meta-data android:name="com.google.android.geo.API_KEY"
  android:value="AIzaS......................"/>
  <meta-data android:name="com.google.android.gms.version"
   android:value="@integer/google_play_services_version" />
)
'firebase
CreateResourceFromFile(Macro, FirebaseAnalytics.GooglePlayBase)
CreateResourceFromFile(Macro, FirebaseAnalytics.Firebase)
CreateResourceFromFile(Macro, FirebaseNotifications.FirebaseNotifications)
'firebase end
Error in Log:
java.lang.SecurityException: "gps" location provider requires ACCESS_FINE_LOCATION permission.
java.lang.SecurityException: Client must have ACCESS_FINE_LOCATION permission to request PRIORITY_HIGH_ACCURACY locations.
 

DonManfred

Expert
Licensed User

ThePuiu

Active Member
Licensed User
I also tried 26 and 28. I don't know what to adjust ... Is there a list somewhere to do?
 

DonManfred

Expert
Licensed User
Top