Spanish Error de compatibilidad con Android 10

Abel De La Ossa

New Member
Licensed User
Hola, recientemente adquirí la versión 9.30 de B4A, y actualicé el SDK a API 29 supongo que con todas las referencias necesarias, me trabaja perfectamente en cuanto a la compilación y generación del .apk, pero al instalar mi App en un dispositivo que tenga Android 10, ya sea que lo tenga instalado de fábrica, o se le haya instalado (el Android 10) mediante un "parche" de actualización, me saca el siguiente error que dice:

"Esta app se creó para una versión anterior de Android, y es posible que no funcione correctamente.
Busca actualizaciones o comunícate con el programador"

En qué ubicación (carpeta de windows) queda el android.jar correcto para compilar para android 10 ?

por que yo lo tomo de :

C:\Program Files (x86)\Android\android-sdk\platforms\android-29\android.jar

Y no funciona.

Alguien me pude ayudar a resolver este problema por favor, gracias y quedo atento.
 

Attachments

Abel De La Ossa

New Member
Licensed User
Hola, gracias por tu respuesta, pero por donde encuentro esas lineas ?

<uses-sdk android:minSdkVersion="5" android:targetSdkVersion="26"/>

En que módulo o como las encuentro en el código de mi app?
 
Top