Android Question error invokedynamic requires --min-sdk-version >= 26

hello dears,
i'm using B4A 10.7 and get the following error:

Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)

I attached project libraries.
 

Attachments

  • photo2556.jpg
    photo2556.jpg
    25.8 KB · Views: 139
Create a new project and add the libraries until you find the problematic one. If it is FirebaseNotifications then follow these instructions: https://www.b4x.com/android/forum/t...ng-after-latest-sdk-update.130694/post-822786
thanks you.
I did what you said but it was not solved,
I wrote the things I did below:
1. Close B4A Sdk manager.
2. Edit: <sdk>\extras\b4a_remote\installed-components.txt
3. Search for com.google.android.datatransport
There will be three matching lines. Delete them.
Open B4A Sdk Manager and install the three recommended items.

This problem occurs when I use the FirebaseNotification library.

i attached Paths Configuration image.
 

Attachments

  • Paths Configuration.png
    Paths Configuration.png
    22.7 KB · Views: 130
Upvote 0
Top