Android Question Error PANIC: Missing emulator Engine program for x86 (SOLVED)

iCAB

Well-Known Member
Licensed User
Hi All,

In an attempt to change the targetSDKVersion to 26 and test against Android 8.0 and up, and since I don't have android phone running 8.0 and up, I wanted to use the Emulator for this.

Steps that I followed (after many attempts to make it work ):
1. Delete c:\android folder
2. Create a new c:\android
3. Download https://dl.google.com/android/repository/sdk-tools-windows-4333796.zip and unzip c:\android
4. Open the IDE and make sure that path is setup properly then run SDK manager and install selected
5. at this point I have platforms android-27 & android-28
6. I setup the path to the android jar to : C:\Android\platforms\android-28\android.jar ( or android-27\...)
7. I tried the default emulator, and it works just fine
8. Now I install Google APIs and Google Play Intel atom 64 images ....
9. Now I create a new AVD using Platform 28 ( I tried all options )

In all the cases I get the above error.
Please advise

Thanks
iCAB
 

DonManfred

Expert
Licensed User
sounds like the emulator only is for 64bit CPU
 
Upvote 0
Top