Android Question Error using library Firebase RemoteConfig

Ederson Kerber

Member
Licensed User
Hi,

I'm implementing a small project(Attached) to test Firebase RemoteConfig.

I followed the guidelines and examples from this post: https://www.b4x.com/android/forum/threads/firebase-remoteconfig.67801/ and from this post: https://www.b4x.com/android/forum/t...emoteconfig-crashlytics-stops-working.125282/

I'm getting the following error to compile:
B4X:
B4A Version: 10.90
Parsing code.    (0.02s)
    Java Version: 11
Building folders structure.    (0.05s)
Compiling code.    (0.04s)
    
ObfuscatorMap.txt file created in Objects folder.
Compiling layouts code.    (0.00s)
Organizing libraries.    (0.00s)
    (AndroidX SDK)
Compiling resources    (0.24s)
Linking resources    (1.15s)
Compiling generated Java code.    (3.05s)
Convert byte code - optimized dex.    Error
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
1 error; aborting

Manifest Editor:
B4X:
AddManifestText(
<uses-sdk android:minSdkVersion="14" android:targetSdkVersion="29"/>
<supports-screens android:largeScreens="true"
    android:normalScreens="true"
    android:smallScreens="true"
    android:anyDensity="true"/>)
SetApplicationAttribute(android:icon, "@drawable/icon")
SetApplicationAttribute(android:label, "$LABEL$")
CreateResourceFromFile(Macro, Themes.LightTheme)
'End of default text.

CreateResourceFromFile(Macro, FirebaseAnalytics.GooglePlayBase)
CreateResourceFromFile(Macro, FirebaseAnalytics.Firebase)
CreateResourceFromFile(Macro, FirebaseAnalytics.FirebaseAnalytics)
CreateResourceFromFile(Macro, FirebaseAnalytics.Crashlytics)

All recommended items in SDK Manager are installed:
SDK Manager_.PNG


B4A Version: 10.90
B4A Sdk Manager: 4.00
SDK version: 6609375

Attached sample project for testing!

Thanks for any help!
 

Attachments

  • test.zip
    10.2 KB · Views: 23

edgar_ortiz

Active Member
Licensed User
Hi I figure:

error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)

needs:
<uses-sdk android:minSdkVersion="26" android:targetSdkVersion="29"/>
 
Upvote 0
Top