Other Getting Xcode 10.3 running on Mohave

Starchild

Active Member
Licensed User
I installed Xcode 10.3 on a new Mohave OS install.
I copied across my B4iBuildServer folder from my old OS.
I thought this would be a quicker way to getting it all running again retaining all the libraries.

I then spent days getting Xcode running with B4i.
Just posting my solution.

Found this post by Amin Asmail

SOLVED!! I had to do a few things to solve this issue which I am documenting here in case someone else has a similar problem:

1. Go to XCODE -> Preferences -> Accounts and add your developer account.
You need to do this if you have just installed a fresh copy of XCODE or are installing on a new MAC computer. Which was my case.

2. I then had to Enable the B4I certificate on my device since I was now using the LOCAL builder and not the HOSTED builder.
Settings -> General -> About -> Certificate Trust Settings

3. And finally, Stupid Me, I forgot to update the Libs folder on the MAC with the Google Maps Framework. My App uses Google Maps and this is required for compilation. See Step 2 of the B4I GoogleMaps Tutorial.

After doing all of the above, the LOCAL builder works just fine and I can compile and simulate my App on the MAC.
-------
These notes nearly worked for me, but...

I was then getting an error Xcode failed to create a build (or something like that) with no other error details to point me to a remedy.

I finally found a post from Erel (for a different issue) about deleting the old UploadedProjects folder in the B4iBuildServer folder on the Mac.

This fixed it for me. Now compiles fine.

-------
I love the B4X forum. It's a great resource.
It really empowers the sole developer.
Hope this post helps others.
 
Top