Android Question Google Playe services minSdkVersion

WAZUMBi

Well-Known Member
Licensed User
Longtime User
So I just installed B4A 3.8 and am updating to AdMob 2.0 with Google Player services on a few of my apps.
The very first one an I get this warning from Google:

You uploaded an APK that uses Google Play services version 5089000. This will only work with Android API levels of 9 and above. It is discouraged to use this Google Play services version unless you have set the minSdkVersion in your manifest to 9 or higher.

I have this in my manifest:

'<uses-sdk androis:minAdkVersion="4" android:targetSdkVersion="14">

Should this be a concern?
I am not sure what limiting the Sdk Version really means.
Will this affect my user base or the app functionality if they upgrade?
 
If you set minsdk to 9 you limit the app to users to need an android os >=1.6
In your case i would update the 4 to 9 to get admob running again...
 
Upvote 0
That's it huh?
Thank you. :)

You´ll lost users who have an android <1.6. But at the time of 2014 I would say this should only affect a very few % of devices. Search google for a list of used android-os´ses and their percentages... I´m sure google will have this info
 
Upvote 0
See here. Versions below 2.2 are not listed here... ummm... i think you´ll limit app using to version >= 2.0.1 i think...

>Data collected during a 7-day period ending on August 12, 2014.
>Any versions with less than 0.1% distribution are not shown.


Maybe the 1.6 was an wrong answer from me, sorry.
 
Upvote 0
Thanks for the info. Very useful.

The warning is gone but now when I upload the new Apk I don't the usual option 'Post Into Production'. It is not there.
I had to save as draft, save as Alpha, and then finally was able to publish.
Odd, but it seems to have worked.

I appear to be having another (unrelated?) issue since upgrading though.
I will post a new thread if I can't figure it out.

Thanks again for the reply.
 
Upvote 0
Upvote 0
Back
Top