Licensed User
major changes

My question is about Elevation data... I would like to know if there is a way to poll elevation data from the GPS library, i don't see any method for that. If this is not currently possible, is there a chance it could be added to your GPS library? If not, is there another GPS library of this type which will give elevation data?

Thanks in advance,


New Member
GPS Com port error

Hi Erel
My builtin GPS receiver on my Win Mobile 6 PDA has been set to COM 4.
However, each time i ran the GPS4PPC app - Connect, it gives a message "Error opening port: 4"

Any idea why it cannot detect my GPS receiver? :sign0148:


Licensed User
Windows2003 SE Test

As I try to test my PPC to develop a new application, I test GPS4PPC.

My device is an ASUS MYpal 730.

When I run GPS4PPC.exe, the soft run well.
If I try to run source code, with the source code GPS4PPC, I got an error 'Error opening port 6'

Note that the same port between the Tries.

Is there any impossibility to try running GPS4PPC code ?


Licensed User
Serialdevice OK

Thank Erel,

With SerialDevice.dll, it's seem work, the error message doesn't appear.

BUT, the program failed. After a few second wait, the program say GPS is deconnected.

The compiled version run well, by the source not. I don't understand what can cause this?

Please what can be the problem this my ASUS 730?
Last edited:


Licensed User
What can I do to progress?

After new Tests, there is the results :
My version : trial version 6.3, .Net Version 2.0.5238 (from Basic4PPC).

When I try GPS4PPC. exe, No problem, soft connect Well using port 6.

When I try GPS4PPC.sbp in run mode, With Serial2.dll, I get the message "error oppening port 6".

When I try GPS4PPC.sbp in run mode, with Serialdevice.dll, I get the message "GPS is Connect", + 2/3second later "GPS is deconnect".

What can I do to test my program. Increase time interval?, Increase counter value?Buy licence to compile soft for test?

Last edited:


Licensed User
GPS is down

HI, after tries and tries, I don't understand what is wrong for my program.
Can you see where i made a mistake, because with compiled program, it doesn't work. (i Buy Basic4PCC today :sign0060:)

I compile program in OPtimized compilation and Serial2.dll, because EREL say GPS4PPC compiled version use Serial2.DLL.



B4X founder
Staff member
Licensed User
Longtime User
I'm sorry if I wasn't clear in my previous post.
The compiled GPS4PPC that you've used was compiled with the legacy compiler and SerialDevice.dll.
You should uncheck the optimized compiler option and replace Serial2.dll with SerialDevice.dll / SerialDesktop.dll.
After compiling your program a config file will also be created. Delete this file as you want to target .Net CF 1.0 and not 2.0.


Licensed User
Put claude is great

After a lot of tests, I make a cab,setup pgm.
I compile as EREL said, and test my program : bad luck, it's doesn't work.

I just test the differences between GPS4PCC V1.05 directory and the directory where I put my program : SerialDevice are different, mine is 16,5Kb, GPS4PCC was 28kb.
I'm copying SerialDevice 28kb in my directory : GPS application doesn't crash!
Put claude is right in is topic

A question stay : Why two version of serialdevice, one in GPS4PCC V1.05 and one in Basic4PCC library ?


Licensed User
the two serialdevice.dll

Hi Erel,
I send you the two serialdevice :
Serialdevice28 came from GPS4PPC V1.05 program (exe to charge into device).
Serialdevice16 came from Basic4PPC standard library.

Thank for all your replies.

Note : For my program, is there an exhaustive documentation for GPS.dll, because i have trouble, with only $GPZDA sentence intercepted.


    7.2 KB · Views: 295
    6.9 KB · Views: 290


Licensed User
GPS NMEA problem

after making a test program that is decode manualy NMEA sentence, I saw that I received a single string with 3 NMEA sentences :
(program use listbox and strsplit to write NMEA sentence)

$GPZDA Date & Time
$GPGGA Global Positioning System Fix Data
$GPRMC Recommended minimum specific GPS/Transit data

These 3 sentences are separated by 2 specials Characters, but I don't know witch one (represented by square:()

Is someone already had this problem?

How can't I decoded this 2 specials characters?

How can't I change this (serial parameters?)?