Android Question Help with targetSDK

ducphu

Active Member
Licensed User
</>AddManifestText(
<uses-sdk android:minSdkVersion="5" android:targetSdkVersion="14"/>
<supports-screens android:largeScreens="true"
android:normalScreens="true"
android:smallScreens="true"
android:anyDensity="true"/>)
SetApplicationAttribute(android:icon, "@drawable/icon")
SetApplicationAttribute(android:label, "$LABEL$")
SetApplicationAttribute(android:theme, "@android:style/Theme.Holo")</>

Hi all, above is my old manifest. When I try updating my app to targetSdk 28
e.g. <uses-sdk android:minSdkVersion="9" android:targetSdkVersion="28"/>

Then I test with 2 devices, Sony Xperia running Android 6.0.1 and Samsung Galaxy S9 running Android 10. I manage to download and run the app in my Samsung device but I'm unable to download it on my Sony device. It says that the app is not compatible. May I know where I did wrong? Thank you.
 

JohnC

Expert
Licensed User
Some questions:
1) If you had the older version of your app already installed on the Sony, did you try uninstalling the previous version before installing the new APK?
2) What permissions does the app require?
3) I see you also changed the minsdkver, did you make any changes to the app besides the sdklevels in the manifest? If so, what?
 
Last edited:
Upvote 0

ducphu

Active Member
Licensed User
1. No. I try updating my current version on the Sony.
2. Network connection
3. Yes, changing the values of some variables, which are sinply used for calculation

Some questions:
1) If you had the older version of your app already installed on the Sony, did you try uninstalling the previous version before installing the new APK?
2) What permissions does the app require?
3) I see you also changed the minsdkver, did you make any changes to the app besides the sdklevels in the manifest? If so, what?
 
Upvote 0

JohnC

Expert
Licensed User
I would try uninstalling the previous version and see if you can then install the new version on the Sony. Lets just see if that's the reason first, then we'll figure out why you can't upgrade an existing version.
 
Last edited:
Upvote 0
Top