iOS Question Hosted builder error

Discussion in 'iOS Questions' started by Gijsen, Dec 4, 2019 at 7:31 PM.

  1. Gijsen

    Gijsen Member Licensed User

    It was working fine, only changing code, and new I get this error.
    I've removed my personal info from the log.
    Would by logical if I changed a certificate, file, ...

    B4i Version: 5.81
    Parsing code. (0.04s)
    Building folders structure. (0.05s)
    Compiling code. (0.32s)
    Compiling layouts code. (0.04s)
    Compiling debugger engine code. (1.78s)
    Building Xcode project (0.82s)
    Sending data to remote compiler. Error
    Out: Build settings from command line:
    ARCHS = arm64
    CODE_SIGN_IDENTITY = iPhone Distribution: xxx
    CONFIGURATION_BUILD_DIR = /Users/administrator/Documents/UploadedProjects/<user id>/Payload
    OTHER_CODE_SIGN_FLAGS = --keychain <user id>
    PRODUCT_NAME = xxx
    PROVISIONING_PROFILE = xxx

    note: Using new build system
    note: Planning build
    note: Constructing build description
    Build system information
    error: No certificate for team 'xxx' matching 'iPhone Distribution: xxx' found: Select a different signing certificate for CODE_SIGN_IDENTITY, a team that matches your selected certificate, or switch to automatic provisioning. (in target 'B4iProject')


    Error: ** BUILD FAILED **
     
  2. Gijsen

    Gijsen Member Licensed User

    I've just tried to buidt another project on the hosted builder. Works.
    Openen my project again from my topic, and this also works now.

    Just curious what the reason could be...
     
  3. Erel

    Erel Administrator Staff Member Licensed User

    Hard to say. The build server clears all caches every hour. Might be some problem that was fixed when the caches were cleared.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice