iOS Question Hosted builder problem


Active Member
Licensed User
Longtime User
Hi, Guys

Really sorry about having to ask this.

I am having problems which appear to be related to updating a provisional profile (which had expired) for a project.

When my provision profile ran out last year, I manage to issue a new one without problems - I must be doing something wrong.

What I have done
1. Went to my apple account and raised a new Provisioning profile for my App - downloaded it to the project's key folder.
2. The compiler then complained the provisioning profile and certificate did not match.
3. So realizing it maybe an old certificate in the keys folder, I downloaded my latest cert from my apple account ios_distribution.cer (I also made a copy and called it default.cer)
4. Then tried to compile again and got the error report below. It now appears to be complaining about the private key - this has not been changed - so I can't work out what is going on!
5. Just for reference I ran ANOTHER PROJECT (I always use a separate Keys file for each project to handle situations like this). This was last worked on Sept 2021 and certs and provision profiles were still valid - That project compiled without problems -

Once again thanks for any help

Dave Morris

The complete compiler error report

B4i Version: 7.80
Parsing code. (0.40s)
Building folders structure. (5.05s)
Compiling code. (4.15s)
Compiling layouts code. (0.32s)
Compiling debugger engine code. (0.10s)
Building Xcode project. (0.28s)
Preparing project for builder. (0.80s)
Project size: 1.38 MB
Sending data to remote compiler. Error
Error: security: SecKeychainDelete: The specified keychain could not be found.

Out: Command line invocation:
/Applications/ -configuration Release PRODUCT_NAME=SuperOrder CONFIGURATION_BUILD_DIR=/Users/administrator/Documents/UploadedProjects/<user id>/Payload "CODE_SIGN_IDENTITY=iPhone Distribution: Momentum Ltd (WNLQ68N9D9)" "OTHER_CODE_SIGN_FLAGS=--keychain <user id>" PROVISIONING_PROFILE=b68a545b-f814-4b1f-8b63-b72f5ec0e0a6 -arch arm64

User defaults from command line:
IDEPackageSupportUseBuiltinSCM = YES

Build settings from command line:
ARCHS = arm64
CODE_SIGN_IDENTITY = iPhone Distribution: Momentum Ltd (WNLQ68N9D9)
CONFIGURATION_BUILD_DIR = /Users/administrator/Documents/UploadedProjects/<user id>/Payload
OTHER_CODE_SIGN_FLAGS = --keychain <user id>
PROVISIONING_PROFILE = b68a545b-f814-4b1f-8b63-b72f5ec0e0a6

note: Using new build system
note: Using codesigning identity override: iPhone Distribution: Momentum Ltd (WNLQ68N9D9)
note: Planning
Analyze workspace

Create build description
Build description signature: 79962eb16a5fb2e8d583af8764793708
Build description path: /Users/administrator/Documents/UploadedProjects/<user id>/build/XCBuildData/79962eb16a5fb2e8d583af8764793708-desc.xcbuild

note: Build preparation complete
warning: Building targets in manual order is deprecated - check "Parallelize build for command-line builds" in the project editor, or set DISABLE_MANUAL_TARGET_ORDER_BUILD_WARNING in any of the targets in the current build to suppress this warning
/Users/administrator/Documents/UploadedProjects/<user id>/B4iProject.xcodeproj: warning: The iOS deployment target 'IPHONEOS_DEPLOYMENT_TARGET' is set to 8.0, but the range of supported deployment target versions is 9.0 to 15.2.99. (in target 'B4iProject' from project 'B4iProject')
error: Missing private key for signing certificate. Failed to locate the private key matching certificate "iPhone Distribution: Momentum Ltd (WNLQ68N9D9)" in the keychain. To sign with this signing certificate, install its private key in your keychain. If you don't have the private key, select a different signing certificate for CODE_SIGN_IDENTITY in the build settings editor. (in target 'B4iProject' from project 'B4iProject')
warning: unexpected C compiler invocation with specified outputs: '/Users/administrator/Documents/UploadedProjects/<user id>/Payload/' (for input: '/Users/administrator/Documents/UploadedProjects/<user id>/main.m') (in target 'B4iProject' from project 'B4iProject')

Error: ** BUILD FAILED **

Andrew (Digitwell)

Well-Known Member
Licensed User
Longtime User
I would suggest you go back to basics.

Did you create the mobile provision with the certificate that you downloaded?

I have occasionally run into similar problems and I find the best thing is to start again from the .cer creation.
Upvote 0