iOS Question The specified keychain could not be found

Jack Cole

Well-Known Member
Licensed User
Longtime User
I have been trying to solve this problem for a couple of months. I've just been working around it. It happens when I try to run an app on an actual device or when trying to build the b4i bridge app. Apps work fine on the simulator. It doesn't matter whether I use the hosted or local builder.

I tried deleting all my certificates and provisioning profiles. I created a new folder for these and started over. I deleted the keys folder on the local mac builder and restarted the builder server program several times. I have tried different apps. I have tried the wildcard provisioning profile and app specific provisioning profiles. I have tried putting in a different user name for the build server in the server settings. I've tried manually downloading profiles in Xcode. Building a production app works fine (as long as I don't get an out of memory error, which happens part of the time). I'm using version 6.01 of the build server.

Here's the full error from the IDE.
B4i Version: 6.30
Parsing code. (0.06s)
Building folders structure. (0.29s)
Compiling code. (0.86s)
Compiling layouts code. (0.03s)
Compiling debugger engine code. (1.79s)
Building Xcode project (0.37s)
Sending data to remote compiler. Error
Failed to parse certificate file.Error: security: SecKeychainDelete: The specified keychain could not be found.

Any ideas?